aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/sslwrap/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index 863a84b9a6b3..dc7ae698189f 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -14,12 +14,14 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ZGabor@CoDe.HU
COMMENT= Another SSL Wrapper application, which uses SSLEay/OpenSSL
-BROKEN= "Does not compile"
-
USE_OPENSSL= YES
+USE_REINPLACE= YES
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
+post-patch:
+ ${REINPLACE_CMD} -e 's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' ${WRKSRC}/s_server.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin/sslwrap
.if !defined(NOPORTDOCS)