aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/fping/Makefile19
-rw-r--r--net/fping/distinfo6
-rw-r--r--net/fping/files/patch-configure.ac10
-rw-r--r--net/fping/pkg-plist8
4 files changed, 26 insertions, 17 deletions
diff --git a/net/fping/Makefile b/net/fping/Makefile
index 5dc7affac33b..aedd8a1d688c 100644
--- a/net/fping/Makefile
+++ b/net/fping/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= fping
-PORTVERSION= 3.16
+PORTVERSION= 4.0
+DISTVERSIONPREFIX= v
CATEGORIES= net ipv6
MAINTAINER= jharris@widomaker.com
@@ -14,20 +15,18 @@ LICENSE_NAME= Previous BSD License
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USES= autoreconf gmake
USE_GITHUB= yes
GH_ACCOUNT= schweikert
-OPTIONS_MULTI= NET
-OPTIONS_MULTI_NET= IPV4 IPV6
-OPTIONS_DEFAULT= IPV4
-OPTIONS_SUB= yes
-
-USES= autoreconf gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --bindir="${PREFIX}/sbin"
+CONFIGURE_ARGS= --bindir="${PREFIX}/sbin" \
+ --enable-ipv6 \
+ --enable-ipv4
INSTALL_TARGET= install-strip
-IPV4_CONFIGURE_ENABLE= ipv4
-IPV6_CONFIGURE_ENABLE= ipv6
+post-install:
+ ${RLN} ${STAGEDIR}${PREFIX}/sbin/fping ${STAGEDIR}${PREFIX}/sbin/fping6
+ ${RLN} ${STAGEDIR}${PREFIX}/man/man8/fping.8 ${STAGEDIR}${PREFIX}/man/man8/fping6.8
.include <bsd.port.mk>
diff --git a/net/fping/distinfo b/net/fping/distinfo
index fd9ffc58e2ef..ee1d0956165e 100644
--- a/net/fping/distinfo
+++ b/net/fping/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491320039
-SHA256 (schweikert-fping-3.16_GH0.tar.gz) = 3e73244f8e67eed777ef6a4280a32c030280789679de5220b484b6cfaca297d4
-SIZE (schweikert-fping-3.16_GH0.tar.gz) = 47240
+TIMESTAMP = 1529347052
+SHA256 (schweikert-fping-v4.0_GH0.tar.gz) = 8c9eac7aeadb5be0daa978cdac5f68ae44b749af0f643e8252b5e3dd4ce32e6a
+SIZE (schweikert-fping-v4.0_GH0.tar.gz) = 52971
diff --git a/net/fping/files/patch-configure.ac b/net/fping/files/patch-configure.ac
new file mode 100644
index 000000000000..131e2dee11ba
--- /dev/null
+++ b/net/fping/files/patch-configure.ac
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2017-04-23 15:53:47 UTC
++++ configure.ac
+@@ -18,6 +18,7 @@ AS_IF([test "x$enable_ipv6" != "xno"], [
+ dnl Test if IPv6 is supported
+ AC_CHECK_HEADERS([netinet/icmp6.h], [have_ipv6="yes"], [], [[
+ #include <netinet/in.h>
++ #include <sys/types.h>
+ ]])
+ ])
+ dnl Can't disable both IPv4 and IPv6
diff --git a/net/fping/pkg-plist b/net/fping/pkg-plist
index 8b7a1f98ea16..66061e07a6c3 100644
--- a/net/fping/pkg-plist
+++ b/net/fping/pkg-plist
@@ -1,6 +1,6 @@
@mode 4555
-%%IPV4%%sbin/fping
-%%IPV6%%sbin/fping6
+sbin/fping
+sbin/fping6
@mode
-%%IPV4%%man/man8/fping.8.gz
-%%IPV6%%man/man8/fping6.8.gz
+man/man8/fping.8.gz
+man/man8/fping6.8.gz