aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/baresip/Makefile5
-rw-r--r--audio/baresip/Makefile.depends1
-rw-r--r--net/libsrtp/Makefile5
-rw-r--r--www/qt5-webengine/Makefile3
4 files changed, 7 insertions, 7 deletions
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
index 2d3b0d8fac5e..90e1a0a9aefa 100644
--- a/audio/baresip/Makefile
+++ b/audio/baresip/Makefile
@@ -26,7 +26,7 @@ PORTEXAMPLES= *
#OPTIONS_NOT_YET_WORKING= ALSA BV32 G722_1 PLC ISAC OPENGLES
OPTIONS_DEFINE= CONS DOCS EXAMPLES FFMPEG G711 G722 G726 GSM GSTREAMER ILBC \
- L16 OPUS OSS PORTAUDIO SDL SNDFILE SPEEX SRTP STDIO UUID V4L V4L2 X11 \
+ L16 OPUS OSS PORTAUDIO SDL SNDFILE SPEEX STDIO UUID V4L V4L2 X11 \
DTLS_SRTP AUBRIDGE VIDBRIDGE HTTPD DSHOW DIRECTFB ACCOUNT \
NATPMP SDL MIW SNAPSHOT SELFVIEW VUMETER AULOOP CONTACT \
MENU PRESENCE SYSLOG VIDLOOP
@@ -47,7 +47,6 @@ MENU_DESC= Interactive menu
OPENGLES_DESC= OpenGL ES video output
PLC_DESC= Packet Loss Concealment
PRESENCE_DESC= Presence module
-SRTP_DESC= Secure RTP module [broken]
STDIO_DESC= stdio input driver
SYSLOG_DESC= Syslog module
UUID_DESC= UUID module
@@ -83,7 +82,7 @@ MAKE_ARGS+= USE_$s=yes
MAKE_ARGS+= HAVE_SPEEXDSP=yes
.endif
-.for o in SRTP V4L DTLS_SRTP V4L2 X11
+.for o in V4L DTLS_SRTP V4L2 X11
. if ${PORT_OPTIONS:M$o}
BROKEN= OPTIONS marked as BROKEN have not been updated to the new Baresip API
. endif
diff --git a/audio/baresip/Makefile.depends b/audio/baresip/Makefile.depends
index 2dbc5bc24e01..6c6c97699641 100644
--- a/audio/baresip/Makefile.depends
+++ b/audio/baresip/Makefile.depends
@@ -20,7 +20,6 @@ PORTAUDIO_DEPEND= ${LOCALBASE}/include/portaudio.h:audio/portaudio
SDL_DEPEND= # Handled with USE_SDL in Makefile
SNDFILE_DEPEND= ${LOCALBASE}/include/sndfile.h:audio/libsndfile
SPEEX_DEPEND= ${LOCALBASE}/include/speex/speex.h:audio/speex
-SRTP_DEPEND= ${LOCALBASE}/include/srtp/srtp.h:net/libsrtp
STDIO_DEPEND= # In base
UUID_DEPEND= ${LOCALBASE}/include/uuid/uuid.h:misc/e2fsprogs-libuuid
V4L_DEPEND= ${LOCALBASE}/include/linux/videodev.h:multimedia/v4l_compat
diff --git a/net/libsrtp/Makefile b/net/libsrtp/Makefile
index a2a7d69b7439..f90d3b2306cc 100644
--- a/net/libsrtp/Makefile
+++ b/net/libsrtp/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libsrtp
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= tijl@FreeBSD.org
@@ -13,6 +13,9 @@ COMMENT= Secure RTP (SRTP) Reference Implementation
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Superseded by libsrtp2
+EXPIRATION_DATE=2018-12-31
+
PORTSCOUT= limit:^1\.
USE_GITHUB= yes
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 50fdddfd93b0..c85bc461e71a 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -20,7 +20,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -45,7 +45,6 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libpng.so:graphics/png \
libre2.so:devel/re2 \
libsnappy.so:archivers/snappy \
- libsrtp.so:net/libsrtp \
libwebp.so:graphics/webp
DISTINFO_FILE= ${.CURDIR}/distinfo