aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/no-login/Makefile4
-rw-r--r--sysutils/no-login/files/patch-Makefile12
-rw-r--r--sysutils/npadmin/Makefile6
-rw-r--r--sysutils/nrg2iso/Makefile5
4 files changed, 17 insertions, 10 deletions
diff --git a/sysutils/no-login/Makefile b/sysutils/no-login/Makefile
index 3268c736db74..6b7a5948341c 100644
--- a/sysutils/no-login/Makefile
+++ b/sysutils/no-login/Makefile
@@ -11,8 +11,6 @@ MASTER_SITE_SUBDIR=wes
MAINTAINER= ports@FreeBSD.org
COMMENT= Refuse a login to a user, and make a note of it in syslog
-PLIST_FILES= bin/nologin
-MAN8= nologin.8
+PLIST_FILES= bin/nologin man/man8/${PORTNAME}.8.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/no-login/files/patch-Makefile b/sysutils/no-login/files/patch-Makefile
new file mode 100644
index 000000000000..e68cdb62bc7f
--- /dev/null
+++ b/sysutils/no-login/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2013-11-15 23:27:54.000000000 +0800
++++ Makefile 2013-11-15 23:28:07.000000000 +0800
+@@ -30,7 +30,7 @@ all: nologin
+ nologin: nologin.c
+
+ install:
+- install -c -o root -g bin -m 755 nologin $(PREFIX)/bin
+- install -c -o root -g wheel -m 444 nologin.8 $(PREFIX)/man/man8
++ install -c -o root -g bin -m 755 nologin $(DESTDIR)$(PREFIX)/bin
++ install -c -o root -g wheel -m 444 nologin.8 $(DESTDIR)$(PREFIX)/man/man8
+ clean:
+ -rm -f *.o *~ nologin
diff --git a/sysutils/npadmin/Makefile b/sysutils/npadmin/Makefile
index 74373304039c..50255c95bdf9 100644
--- a/sysutils/npadmin/Makefile
+++ b/sysutils/npadmin/Makefile
@@ -10,12 +10,10 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= SNMP based command line network printer management tool
-MAN1= npadmin.1
-PLIST_FILES= bin/npadmin
-
GNU_CONFIGURE= yes
-NO_STAGE= yes
+PLIST_FILES= bin/npadmin man/man1/${PORTNAME}.1.gz
+
pre-configure:
${RM} ${WRKSRC}/getopt.h ${WRKSRC}/getopt1.c
diff --git a/sysutils/nrg2iso/Makefile b/sysutils/nrg2iso/Makefile
index ad9a43df2927..13c45a9fd09a 100644
--- a/sysutils/nrg2iso/Makefile
+++ b/sysutils/nrg2iso/Makefile
@@ -9,17 +9,16 @@ MASTER_SITES= http://gregory.kokanosky.free.fr/v4/linux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert Nero .nrg CD-Image format to ISO
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/nrg2iso
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -E \
-e 's|gcc|${CC} ${CFLAGS}|' \
${BUILD_WRKSRC}/${MAKEFILE}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/nrg2iso ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/nrg2iso ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>