aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/updatedd/Makefile43
-rw-r--r--dns/updatedd/distinfo1
-rw-r--r--dns/updatedd/files/patch-updatedd.c15
-rw-r--r--dns/updatedd/pkg-descr15
-rw-r--r--dns/updatedd/pkg-plist17
6 files changed, 92 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 0b6d0071f148..632d9d6fc67e 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -60,6 +60,7 @@
SUBDIR += sleuth
SUBDIR += staticcharge
SUBDIR += totd
+ SUBDIR += updatedd
SUBDIR += walker
SUBDIR += weedns_sc
SUBDIR += zonecheck
diff --git a/dns/updatedd/Makefile b/dns/updatedd/Makefile
new file mode 100644
index 000000000000..ec9bd488f219
--- /dev/null
+++ b/dns/updatedd/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: updatedd
+# Date created: 2003-12-02
+# Whom: geniusj@ods.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= updatedd
+PORTVERSION= 1.8
+CATEGORIES= dns
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}-1
+
+MAINTAINER= geniusj@ods.org
+COMMENT= Dynamic DNS Update Client supporting multiple services
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LIBDIR= ${PREFIX}/lib/${PORTNAME}
+
+MAN1= updatedd.1
+DOCS= Documentation/README.* Documentation/rc_updatedd_*
+
+# Default Service Plugin
+# Valid services: dyndns, hn, noip, ods, ovh
+DEFAULTPLUGIN?= ods
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/updatedd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/*.1 ${MAN1PREFIX}/man/man1
+ @${MKDIR} ${LIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/plugins/*.so ${LIBDIR}
+ ${LN} -sf ${LIBDIR}/${DEFAULTPLUGIN}.so ${LIBDIR}/default.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/updatedd/distinfo b/dns/updatedd/distinfo
new file mode 100644
index 000000000000..c02eecedbf20
--- /dev/null
+++ b/dns/updatedd/distinfo
@@ -0,0 +1 @@
+MD5 (updatedd_1.8-1.tar.gz) = 15d59db0fd708d66f241f1ffa818b5be
diff --git a/dns/updatedd/files/patch-updatedd.c b/dns/updatedd/files/patch-updatedd.c
new file mode 100644
index 000000000000..0bfe9b3f1bac
--- /dev/null
+++ b/dns/updatedd/files/patch-updatedd.c
@@ -0,0 +1,15 @@
+--- src.bak/updatedd.c Tue Dec 2 15:50:39 2003
++++ src/updatedd.c Tue Dec 2 15:50:58 2003
+@@ -33,11 +33,7 @@
+ #define MAXLIBS 10
+ #define MAXDATA 256
+
+-#ifndef __linux__
+-# define LIB_FUNC "_dyndns"
+-#else
+-# define LIB_FUNC "dyndns"
+-#endif
++#define LIB_FUNC "dyndns"
+
+ typedef void (*fptr)(int, char**);
+
diff --git a/dns/updatedd/pkg-descr b/dns/updatedd/pkg-descr
new file mode 100644
index 000000000000..6d0bbfcb8aaf
--- /dev/null
+++ b/dns/updatedd/pkg-descr
@@ -0,0 +1,15 @@
+Updatedd is a client to update dynamic dns settings.
+With the use of the pppd ip-up script it can update
+these settings automatically for you.
+Updatedd does not run as a daemon.
+
+It is divided into one main program and one plugin for each
+supported service. The plugins are dynamic libraries which
+are loaded by the main program. So it is possible to remove
+support for services you don't need.
+
+Supported Services:
+ods.org, dyndns.org, ovh.net, no-ip.org, hn.org
+
+Author: Philipp Benner <philipp_benner (at) gmx (dot) de>
+WWW: http://pb.gotdns.org/
diff --git a/dns/updatedd/pkg-plist b/dns/updatedd/pkg-plist
new file mode 100644
index 000000000000..75706ed43d92
--- /dev/null
+++ b/dns/updatedd/pkg-plist
@@ -0,0 +1,17 @@
+@comment $FreeBSD$
+bin/updatedd
+lib/updatedd/default.so
+lib/updatedd/dyndns.so
+lib/updatedd/hn.so
+lib/updatedd/noip.so
+lib/updatedd/ods.so
+lib/updatedd/ovh.so
+@dirrm lib/updatedd
+%%PORTDOCS%%%%DOCSDIR%%/README.english
+%%PORTDOCS%%%%DOCSDIR%%/README.german
+%%PORTDOCS%%%%DOCSDIR%%/rc_updatedd_dyndns
+%%PORTDOCS%%%%DOCSDIR%%/rc_updatedd_hn
+%%PORTDOCS%%%%DOCSDIR%%/rc_updatedd_noip
+%%PORTDOCS%%%%DOCSDIR%%/rc_updatedd_ods
+%%PORTDOCS%%%%DOCSDIR%%/rc_updatedd_ovh
+%%PORTDOCS%%@dirrm %%DOCSDIR%%