aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-exifread/Makefile18
-rw-r--r--graphics/py-exifread/distinfo2
-rw-r--r--graphics/py-exifread/pkg-descr6
4 files changed, 27 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5769da1b1504..87df8f3b54b1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -826,6 +826,7 @@
SUBDIR += py-django-easy-thumbnails
SUBDIR += py-editobj
SUBDIR += py-exif
+ SUBDIR += py-exifread
SUBDIR += py-exiv2
SUBDIR += py-freeimagepy
SUBDIR += py-gchartwrapper
diff --git a/graphics/py-exifread/Makefile b/graphics/py-exifread/Makefile
new file mode 100644
index 000000000000..8f00af32ffc8
--- /dev/null
+++ b/graphics/py-exifread/Makefile
@@ -0,0 +1,18 @@
+# Created by: Mikhail Teterin <mi@aldan.algebra.com>
+# $FreeBSD$
+
+PORTNAME= ExifRead
+PORTVERSION= 2.1.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Read Exif metadata from tiff and jpeg files
+
+LICENSE= BSD
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-exifread/distinfo b/graphics/py-exifread/distinfo
new file mode 100644
index 000000000000..ae368e8b3b00
--- /dev/null
+++ b/graphics/py-exifread/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ExifRead-2.1.2.tar.gz) = 79e244f2eb466709029e8806fe5e2cdd557870c3db5f68954db0ef548d9320ad
+SIZE (ExifRead-2.1.2.tar.gz) = 33159
diff --git a/graphics/py-exifread/pkg-descr b/graphics/py-exifread/pkg-descr
new file mode 100644
index 000000000000..5d21dba39b40
--- /dev/null
+++ b/graphics/py-exifread/pkg-descr
@@ -0,0 +1,6 @@
+Easy to use Python module to extract Exif metadata from tiff and
+jpeg files.
+
+Originally written by Gene Cash & Thierry Bousch.
+
+WWW: https://github.com/ianare/exif-py