aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/linux-shoutcast/Makefile12
-rw-r--r--audio/linux-shoutcast/pkg-install7
-rw-r--r--audio/shoutcast/Makefile10
-rw-r--r--audio/shoutcast/pkg-install7
-rw-r--r--databases/gdbm/Makefile2
-rw-r--r--devel/terminality/Makefile6
-rw-r--r--dns/dualserver/Makefile4
-rw-r--r--editors/sted/Makefile4
-rw-r--r--net/cryptcat/Makefile2
-rw-r--r--security/chroot_safe/Makefile1
-rw-r--r--security/symbion-sslproxy/Makefile2
-rw-r--r--textproc/gsed/Makefile6
12 files changed, 25 insertions, 38 deletions
diff --git a/audio/linux-shoutcast/Makefile b/audio/linux-shoutcast/Makefile
index 19261aa263e9..f6aa7a671494 100644
--- a/audio/linux-shoutcast/Makefile
+++ b/audio/linux-shoutcast/Makefile
@@ -36,11 +36,11 @@ post-patch:
${WRKSRC}/sc_serv.conf
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${TARGETDIR}/sbin
- @${MKDIR} ${TARGETDIR}/etc/shoutcast
- @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf.sample
- @[ -f ${TARGETDIR}/etc/shoutcast/sc_serv.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf
+ @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
+ @${MKDIR} ${PREFIX}/etc/shoutcast
+ @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -49,6 +49,6 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${BRANDELF} -t Linux ${TARGETDIR}/sbin/sc_serv
+ @${BRANDELF} -t Linux ${PREFIX}/sbin/sc_serv
.include <bsd.port.mk>
diff --git a/audio/linux-shoutcast/pkg-install b/audio/linux-shoutcast/pkg-install
index 75387ad52143..2b6c96b93a64 100644
--- a/audio/linux-shoutcast/pkg-install
+++ b/audio/linux-shoutcast/pkg-install
@@ -8,12 +8,7 @@ SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
SC_HOME=/nonexistent
-
-if [ -n "${DESTDIR}" ] ; then
- PW="/usr/sbin/chroot ${DESTDIR} /usr/sbin/pw"
-else
- PW="/usr/sbin/pw"
-fi
+PW="/usr/sbin/pw"
if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
gid=210
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index 50e472f9c30a..4f70aa0d13ad 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -41,11 +41,11 @@ post-patch:
${WRKSRC}/sc_serv.conf
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${TARGETDIR}/sbin
- @${MKDIR} ${TARGETDIR}/etc/shoutcast
- @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf.sample
- @[ -f ${TARGETDIR}/etc/shoutcast/sc_serv.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf
+ @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
+ @${MKDIR} ${PREFIX}/etc/shoutcast
+ @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
diff --git a/audio/shoutcast/pkg-install b/audio/shoutcast/pkg-install
index 75387ad52143..2b6c96b93a64 100644
--- a/audio/shoutcast/pkg-install
+++ b/audio/shoutcast/pkg-install
@@ -8,12 +8,7 @@ SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
SC_HOME=/nonexistent
-
-if [ -n "${DESTDIR}" ] ; then
- PW="/usr/sbin/chroot ${DESTDIR} /usr/sbin/pw"
-else
- PW="/usr/sbin/pw"
-fi
+PW="/usr/sbin/pw"
if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
gid=210
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index af7f87610186..0e5c683ca55b 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -40,8 +40,6 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} "s|prefix = @prefix@|prefix = ${TARGETDIR}|" \
- ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|LIBS = @LIBS@ -lc|LIBS = @LIBS@|" \
-e "s|BINOWN = bin|BINOWN = root|" -e "s|BINGRP = bin|BINGRP = wheel|" \
-e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
diff --git a/devel/terminality/Makefile b/devel/terminality/Makefile
index 0f8eeb40edc8..8dea11449a10 100644
--- a/devel/terminality/Makefile
+++ b/devel/terminality/Makefile
@@ -16,9 +16,9 @@ MAINTAINER= gabor@FreeBSD.org
COMMENT= A cross-platform terminal manipulation library
do-install:
- @${MKDIR} ${TARGETDIR}/include/tn
- ${INSTALL_DATA} ${WRKSRC}/*.h ${TARGETDIR}/include/tn
- ${INSTALL_DATA} ${WRKSRC}/libtn.a ${TARGETDIR}/lib
+ @${MKDIR} ${PREFIX}/include/tn
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/tn
+ ${INSTALL_DATA} ${WRKSRC}/libtn.a ${PREFIX}/lib
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/screenshot
${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
diff --git a/dns/dualserver/Makefile b/dns/dualserver/Makefile
index 1096ed751e8b..43d05c485f4c 100644
--- a/dns/dualserver/Makefile
+++ b/dns/dualserver/Makefile
@@ -28,7 +28,7 @@ do-build:
${CXX} -o ${WRKSRC}/dualserver ${WRKSRC}/dualserver.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dualserver ${TARGETDIR}/sbin
- ${INSTALL_DATA} ${WRKSRC}/dualserver.ini ${TARGETDIR}/etc/dualserver.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/dualserver ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/dualserver.ini ${PREFIX}/etc/dualserver.conf.sample
.include <bsd.port.post.mk>
diff --git a/editors/sted/Makefile b/editors/sted/Makefile
index 17c90955427e..3fb155ec38ff 100644
--- a/editors/sted/Makefile
+++ b/editors/sted/Makefile
@@ -27,8 +27,8 @@ post-patch:
@${REINPLACE_CMD} "s|<curses.h>|<ncurses.h>|" ${WRKSRC}/sted.c
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/sted ${TARGETDIR}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/sted.1 ${TARGETDIR}/man/man1
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/sted ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/sted.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
diff --git a/net/cryptcat/Makefile b/net/cryptcat/Makefile
index 9b0551d9631c..42de22537914 100644
--- a/net/cryptcat/Makefile
+++ b/net/cryptcat/Makefile
@@ -24,7 +24,7 @@ PLIST_FILES= bin/cryptcat
PORTDOCS= README.cryptcat
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cryptcat ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cryptcat ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
diff --git a/security/chroot_safe/Makefile b/security/chroot_safe/Makefile
index 4ac7c8f70c61..bde7d13d240a 100644
--- a/security/chroot_safe/Makefile
+++ b/security/chroot_safe/Makefile
@@ -23,7 +23,6 @@ PLIST_DIRS= libexec/chroot_safe
post-patch:
${REINPLACE_CMD} -e 's|CXX=g++|CXX?=c++|' \
-e 's|-o chroot_safe.so|chroot_safe.cpp -o chroot_safe.so|' \
- -e 's|prefix=@prefix@|prefix=${DESTDIR}@prefix@|' \
${WRKSRC}/Makefile.in
${REINPLACE_CMD} 's|chroot(1)|chroot(8)|' ${WRKSRC}/chroot_safe.1.in
${REINPLACE_CMD} 's|putenv|unsetenv|' ${WRKSRC}/chroot_safe.cpp
diff --git a/security/symbion-sslproxy/Makefile b/security/symbion-sslproxy/Makefile
index 89e045bc8144..b7dd8c254df6 100644
--- a/security/symbion-sslproxy/Makefile
+++ b/security/symbion-sslproxy/Makefile
@@ -30,7 +30,7 @@ post-patch:
-e 's|CFLAGS =|CFLAGS +=|' ${WRKSRC}/Makefile.global
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ssl_proxy ${TARGETDIR}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ssl_proxy ${PREFIX}/sbin
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index c5d6426984a8..2942e28926aa 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -27,11 +27,11 @@ MAN1= gsed.1
# Local variables
PATCH_SUBDIRS= . doc lib sed
-DATADIR= ${TARGETDIR}/share/${PKGBASE}
+DATADIR= ${PREFIX}/share/${PKGBASE}
SAMP_FILES= binary*.sed dc.sed
-EXAMPLESDIR= ${TARGETDIR}/share/examples/${PKGBASE}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
PORTDOCS= AUTHORS BUGS COPYING COPYING.DOC NEWS README THANKS
-DOCSDIR= ${TARGETDIR}/share/doc/${PKGBASE}
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
.include <bsd.port.pre.mk>