aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/samba-devel/Makefile12
-rw-r--r--net/samba3/Makefile12
2 files changed, 24 insertions, 0 deletions
diff --git a/net/samba-devel/Makefile b/net/samba-devel/Makefile
index 4e224afc9c7d..7a7b65ad1dec 100644
--- a/net/samba-devel/Makefile
+++ b/net/samba-devel/Makefile
@@ -28,6 +28,18 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if defined(WITH_QUOTAS)
+CONFIGURE_ARGS+= --with-quotas
+.endif
+
+.if defined(WITH_UTMP)
+CONFIGURE_ARGS+= --with-utmp
+.endif
+
+.if defined(WITH_MSDFS)
+CONFIGURE_ARGS+= --with-msdfs
+.endif
+
# directories
VARDIR= /var
SAMBA_SPOOL= ${VARDIR}/spool/samba
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 4e224afc9c7d..7a7b65ad1dec 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -28,6 +28,18 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
.endif
+.if defined(WITH_QUOTAS)
+CONFIGURE_ARGS+= --with-quotas
+.endif
+
+.if defined(WITH_UTMP)
+CONFIGURE_ARGS+= --with-utmp
+.endif
+
+.if defined(WITH_MSDFS)
+CONFIGURE_ARGS+= --with-msdfs
+.endif
+
# directories
VARDIR= /var
SAMBA_SPOOL= ${VARDIR}/spool/samba