aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ascii2pdf/Makefile26
-rw-r--r--textproc/ascii2pdf/distinfo1
-rw-r--r--textproc/ascii2pdf/pkg-comment1
-rw-r--r--textproc/ascii2pdf/pkg-descr11
-rw-r--r--textproc/ascii2pdf/pkg-plist1
6 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 603ec43da416..bb02d4e55a54 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -3,6 +3,7 @@
SUBDIR += agrep
SUBDIR += antiword
+ SUBDIR += ascii2pdf
SUBDIR += aspell
SUBDIR += br-ispell
SUBDIR += british-ispell
diff --git a/textproc/ascii2pdf/Makefile b/textproc/ascii2pdf/Makefile
new file mode 100644
index 000000000000..26e6418d5fe6
--- /dev/null
+++ b/textproc/ascii2pdf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ascii2pdf
+# Date created: 20 January 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= ascii2pdf
+PORTVERSION= 0.9.1
+CATEGORIES= textproc
+MASTER_SITES= http://bulldog.tzo.org/ascii2pdf/
+DISTNAME= ${PORTNAME}-0.9.1
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/PDF/Create.pm:${PORTSDIR}/textproc/p5-PDF-Create
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/ascii2pdf ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/textproc/ascii2pdf/distinfo b/textproc/ascii2pdf/distinfo
new file mode 100644
index 000000000000..d03e70791196
--- /dev/null
+++ b/textproc/ascii2pdf/distinfo
@@ -0,0 +1 @@
+MD5 (ascii2pdf-0.9.1.tar.gz) = f7a61d8ce260c899733d7123583e71c4
diff --git a/textproc/ascii2pdf/pkg-comment b/textproc/ascii2pdf/pkg-comment
new file mode 100644
index 000000000000..413e2a657645
--- /dev/null
+++ b/textproc/ascii2pdf/pkg-comment
@@ -0,0 +1 @@
+A perl script to convert text files to PDF files
diff --git a/textproc/ascii2pdf/pkg-descr b/textproc/ascii2pdf/pkg-descr
new file mode 100644
index 000000000000..efc3ca7f86d3
--- /dev/null
+++ b/textproc/ascii2pdf/pkg-descr
@@ -0,0 +1,11 @@
+
+ascii2pdf is a small perl script that uses the PDF::Create module to convert
+ascii text files into pdf files, with options to set the font, point size,
+margins, and page orientation.
+
+For more details, please see the ascii2pdf homepage:
+
+WWW: http://bulldog.tzo.org/ascii2pdf/ascii2pdf.html
+
+- Pete
+petef@databits.net
diff --git a/textproc/ascii2pdf/pkg-plist b/textproc/ascii2pdf/pkg-plist
new file mode 100644
index 000000000000..dbb71cf65cc6
--- /dev/null
+++ b/textproc/ascii2pdf/pkg-plist
@@ -0,0 +1 @@
+bin/ascii2pdf