aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/unison-devel/Makefile9
-rw-r--r--net/unison-nox11/Makefile2
-rw-r--r--net/unison/Makefile10
-rw-r--r--net/unison232/Makefile11
-rw-r--r--net/unison240/Makefile10
5 files changed, 16 insertions, 26 deletions
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 9c09f0c639ce..f1ab9d58377c 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -18,6 +18,8 @@ IGNORE= No devel release available. \
LICENSE= GPLv3
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
WANT_GNOME= yes
@@ -39,18 +41,13 @@ ALL_TARGET= unison all
.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
icotool:${PORTSDIR}/graphics/icoutils
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
-CONFLICTS+= ocaml-nox11*
SUB_FILES+= ${PORTNAME}.desktop
.else
MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
.endif
diff --git a/net/unison-nox11/Makefile b/net/unison-nox11/Makefile
index 4608133ecb3f..526d495a9f30 100644
--- a/net/unison-nox11/Makefile
+++ b/net/unison-nox11/Makefile
@@ -1,7 +1,7 @@
# Created by: Boris Samorodov <bsam@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -nox11
MAINTAINER= bsam@FreeBSD.org
diff --git a/net/unison/Makefile b/net/unison/Makefile
index b7d3d930b098..7404beb02dfa 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unison
PORTVERSION= 2.48.3
+PORTREVISION?= 1
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
@@ -14,6 +15,8 @@ COMMENT?= User-level file synchronization tool
LICENSE= GPLv3
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
WANT_GNOME= yes
@@ -35,18 +38,13 @@ OPTIONS_DEFAULT?= DOCS X11
.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
icotool:${PORTSDIR}/graphics/icoutils
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
-CONFLICTS+= ocaml-nox11*
SUB_FILES+= ${PORTNAME}.desktop
.else
MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
.endif
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index 1663d8eaec79..53190fb7f399 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unison
PORTVERSION= 2.32.52
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
PKGNAMESUFFIX= 232
@@ -17,6 +17,8 @@ COMMENT= User-level file synchronization tool
LICENSE= GPLv3
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
WANT_GNOME= yes
@@ -37,18 +39,13 @@ OPTIONS_DEFAULT= DOCS X11
.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
icotool:${PORTSDIR}/graphics/icoutils
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
-CONFLICTS+= ocaml-nox11*
SUB_FILES+= ${PORTNAME}.desktop
.else
MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
.endif
.if ${PORT_OPTIONS:MX11}
diff --git a/net/unison240/Makefile b/net/unison240/Makefile
index 3ee3a5b9806e..96b3edd392dc 100644
--- a/net/unison240/Makefile
+++ b/net/unison240/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unison
PORTVERSION= 2.40.128
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
PKGNAMESUFFIX= 240
@@ -15,6 +16,8 @@ COMMENT?= User-level file synchronization tool
LICENSE= GPLv3
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
WANT_GNOME= yes
@@ -36,18 +39,13 @@ OPTIONS_DEFAULT?= DOCS X11
.if ${PORT_OPTIONS:MX11}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
- lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
icotool:${PORTSDIR}/graphics/icoutils
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
-CONFLICTS+= ocaml-nox11*
SUB_FILES+= ${PORTNAME}.desktop
.else
MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
-PATCH_DEPENDS+= ${BUILD_DEPENDS}
PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
.endif