aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/cclient/Makefile30
-rw-r--r--mail/courier-imap/Makefile29
-rw-r--r--mail/courier-pythonfilter/Makefile110
-rw-r--r--security/courier-authlib/Makefile4
-rw-r--r--security/courier-authlib/Makefile.dep18
-rw-r--r--security/courier-authlib/Makefile.opt17
6 files changed, 97 insertions, 111 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index c8e7030f69a9..c87df467cc22 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cclient
-# Date created: 2 July 2000
-# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
-#
+# Created by: Kelly Yancey <kbyanc@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cclient
PORTVERSION= 2007f
@@ -22,16 +18,16 @@ COMMENT= Mark Crispin's C-client mail access routines
LICENSE= AL2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-OPTIONS= SSL "Compile with SSL support" on \
- SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
- IPV6 "Support IPv6" on \
- MBX_DEFAULT "Use MBX as default mailbox format" off
+OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT IPV6 MBX_DEFAULT
+OPTIONS_DEFAULT= SSL
+SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
+MBX_DEFAULT_DESC= Use MBX as default mailbox format
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.options.mk>
-.if ! defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
.endif
@@ -39,10 +35,10 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
ALL_TARGET= bsf
-.if defined(WITHOUT_SSL)
+.if ! ${PORT_OPTIONS:MSSL}
MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
-.if defined(WITH_SSL_AND_PLAINTEXT)
+.if ${PORT_OPTIONS:MSSL_AND_PLAINTEXT}
MAKE_ARGS+= SSLTYPE=unix SSLDIR=${OPENSSLDIR}
.else
MAKE_ARGS+= SSLTYPE=unix.nopwd SSLDIR=${OPENSSLDIR}
@@ -65,16 +61,16 @@ post-patch:
s:/etc/ssl/private:${PREFIX}/certs:g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s:/etc/c-client.cf:${PREFIX}/etc/c-client.cf:" \
${WRKSRC}/src/osdep/unix/env_unix.h
-.if ! defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${REINPLACE_CMD} -e " \
s:SSLINCLUDE=/usr/include/openssl SSLLIB=/usr/lib:SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}: \
" ${WRKSRC}/Makefile
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
@${REINPLACE_CMD} -e "s|^IP=4|IP=6|" ${WRKSRC}/Makefile \
${WRKSRC}/src/osdep/unix/Makefile
.endif
-.if defined(WITH_MBX_DEFAULT)
+.if ${PORT_OPTIONS:MMBX_DEFAULT}
@${REINPLACE_CMD} -e "s|^CREATEPROTO=unixproto|CREATEPROTO=mbxproto|" \
${WRKSRC}/src/osdep/unix/Makefile
.endif
@@ -91,7 +87,7 @@ PORTREV_H= ${WRKDIR}/portrevision.h
post-build:
@${ECHO_CMD} "#define CCLIENT_PORTVERSION \"${PORTVERSION}\"" >${PORTREV_H}
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${ECHO_CMD} "#define CCLIENT_SSLENABLED \"yes\"" >>${PORTREV_H}
.else
@${ECHO_CMD} "#define CCLIENT_SSLENABLED \"no\"" >>${PORTREV_H}
@@ -113,7 +109,7 @@ do-install:
post-install:
${INSTALL_DATA} ${PORTREV_H} ${PREFIX}/include/c-client
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${ECHO} "================================================================================"
@${ECHO} "Warning: You have chosen to include SSL support. Applications/ports that use"
@${ECHO} "the cclient library but do not support SSL may stop working or have problems"
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 47b631697d6c..8980628be26b 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courierimap
-# Date created: 19 Feb 2000
-# Whom: Neil Blakey-Milner
-#
+# Created by: Neil Blakey-Milner
# $FreeBSD$
-#
PORTNAME= courier-imap
PORTVERSION= 4.13
@@ -36,10 +32,9 @@ MAKE_ENV:= ${CONFIGURE_ENV}
# WITH_SYSLOG_FACILITY: The syslogfacility to use
#
-OPTIONS= FAM "Build in fam support for IDLE command" off \
- TRASHQUOTA "Include deleted mails in the quota" off \
- GDBM "Use gdbm db instead of system bdb" off \
- IPV6 "Build with IPv6 support" on \
+OPTIONS_DEFINE= FAM TRASHQUOTA GDBM IPV6
+FAM_DESC= Fam support for IDLE command
+TRASHQUOTA_DESC= Include deleted mails in the quota
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.opt)
.include "${.CURDIR}/../../security/courier-authlib/Makefile.opt"
@@ -67,12 +62,12 @@ CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
.include "${.CURDIR}/../../security/courier-authlib/Makefile.dep"
.endif
-.if defined(WITH_SYSLOG_FACILITY)
+.if ${PORT_OPTIONS:MSYSLOG_FACILITY}
CONFIGURE_ARGS+=--with-syslog=${WITH_SYSLOG_FACILITY}
.endif
-.if defined(WITH_AUTH_USERDB)
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MAUTH_USERDB}
+.if ${PORT_OPTIONS:MGDBM}
CONFIGURE_ARGS+=--with-db=gdbm --with-userdb=${USERDB}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.else
@@ -80,15 +75,15 @@ CONFIGURE_ARGS+=--with-db=db --with-userdb=${USERDB}
.endif
.endif
-.if defined(WITHOUT_IPV6)
+.if ! ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+=--without-ipv6
.endif
-.if defined(WITH_TRASHQUOTA)
+.if ${PORT_OPTIONS:MTRASHQUOTA}
CONFIGURE_ARGS+=--with-trashquota
.endif
-.if defined(WITH_FAM)
+.if ${PORT_OPTIONS:MFAM}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_FAM= yes
@@ -106,7 +101,7 @@ EXTRA_DOCS= AUTHORS INSTALL NEWS imap/ChangeLog imap/README \
maildir/README.sharedfolders.txt tcpd/README.couriertls \
post-patch:
-.if !defined(WITH_FAM)
+.if ! ${PORT_OPTIONS:MFAM}
@${REINPLACE_CMD} -e 's|$$LIBFAM||g; s|HAVE_FAM|DO_NOT_HAVE_FAM|g' \
${WRKSRC}/maildir/configure
.endif
@@ -124,7 +119,7 @@ post-install:
.for i in imapd pop3d
${INSTALL_DATA} ${WRKSRC}/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for a in ${EXTRA_DOCS}
${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
diff --git a/mail/courier-pythonfilter/Makefile b/mail/courier-pythonfilter/Makefile
index 328e142c8072..bfa6ed26fd25 100644
--- a/mail/courier-pythonfilter/Makefile
+++ b/mail/courier-pythonfilter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-pythonfilter
-# Date created: Jun 19, 2006
-# Whom: Milan Obuch
-#
+# Created by: Milan Obuch
# $FreeBSD$
-#
PORTNAME= courier-pythonfilter
PORTVERSION= 1.6
@@ -26,45 +22,51 @@ MAILGID= 465
LOCALSTATEDIR= /var/spool/courier
SCRIPTSDIR= ${PREFIX}/libexec/filters
-OPTIONS= DEBUG "debug module" on \
- NODUPLICATES "noduplicates module" off \
- LOCALSENDERS "localsenders module" off \
- CLAMAV_CLAMD "clamav filter with py-pyclamd \ mutually" off \
- CLAMAV_LIB "clamav filter with py-clamav / exclusive" off \
- SPAMASSASSIN "spamassassin module" off \
- AUTO_WHITELIST "auto_whitelist module" off \
- WHITELIST_RELAY "whitelist_relayclients module" on \
- WHITELIST_AUTH "whitelist_auth module" on \
- WHITELIST_BLOCK "whitelist_block module" off \
- WHITELIST_DNSWL "whitelist_dnswl module" off \
- WHITELIST_SPF "whitelist_spf module" off \
- DELIVEREDTO "deliveredto module" off \
- PRIVATEADDR "privateaddr module" off \
- SPFCHECK "spfcheck module" off \
- NOSUCCESSDSN "nosuccessdsn module" off \
- COMEAGAIN "comeagain module" off \
- GREYLIST "greylist module" off \
- DIALBACK "dialback module" off \
- RATELIMIT "ratelimit module" off \
- ATTACHMENTS "attachments module" off \
- QUOTA "quota module" off
+OPTIONS_DEFINE= DEBUG NODUPLICATES LOCALSENDERS SPAMASSASSIN AUTO_WHITELIST WHITELIST_RELAY WHITELIST_AUTH \
+ WHITELIST_BLOCK WHITELIST_DNSWL WHITELIST_DNSWL DELIVEREDTO PRIVATEADDR SPFCHECK NOSUCCESSDSN \
+ COMEAGAIN GREYLIST DIALBACK RATELIMIT ATTACHMENTS QUOTA
+
+DEBUG_DESC= debug module
+NODUPLICATES_DESC= noduplicates module
+LOCALSENDERS_DESC= localsenders module
+CLAMAV_CLAMD_DESC= clamav filter with py-pyclamd \ mutually
+CLAMAV_LIB_DESC= clamav filter with py-clamav / exclusive
+SPAMASSASSIN_DESC= spamassassin module
+AUTO_WHITELIST_DESC= auto_whitelist module
+WHITELIST_RELAY_DESC= whitelist_relayclients module
+WHITELIST_AUTH_DESC= whitelist_auth module
+WHITELIST_BLOCK_DESC= whitelist_block module
+WHITELIST_DNSWL_DESC= whitelist_dnswl module
+WHITELIST_SP_DESC= Fwhitelist_spf module
+DELIVEREDTO_DESC= deliveredto module
+PRIVATEADDR_DESC= privateaddr module
+SPFCHECK_DESC= spfcheck module
+NOSUCCESSDSN_DESC= nosuccessdsn module
+COMEAGAIN_DESC= comeagain module
+GREYLIST_DESC= greylist module
+DIALBACK_DESC= dialback module
+RATELIMIT_DESC= ratelimit module
+ATTACHMENTS_DESC= attachments module
+QUOTA_DESC= quota module
+
+OPTIONS_RADIO= RG1
+OPTIONS_RADIO_RG1= CLAMAV_CLAMD CLAMAV_LIB
+RG1_DESC= ClamAV Filter Option
+
+OPTIONS_DEFAULT= DEBUG WHITELIST_RELAY WHITELIST_AUTH
.include <bsd.port.pre.mk>
PYDISTUTILS_INSTALLARGS:=${PYDISTUTILS_INSTALLARGS} --install-scripts=${SCRIPTSDIR}
-.if defined(WITH_CLAMAV_CLAMD) && !defined(WITH_CLAMAV_LIB)
+.if ${PORT_OPTIONS:MCLAMAV_CLAMD) && ! ${PORT_OPTIONS:MCLAMAV_LIB}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pyclamd.py:${PORTSDIR}/security/py-pyclamd
.endif
-.if defined(WITH_CLAMAV_LIB) && !defined(WITH_CLAMAV_CLAMD)
+.if ${PORT_OPTIONS:MCLAMAV_LIB) && ! ${PORT_OPTIONS:MCLAMAV_CLAMD}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pyclamav.so:${PORTSDIR}/security/py-clamav
.endif
-.if defined(WITH_CLAMAV_CLAMD) && defined(WITH_CLAMAV_LIB)
-BROKEN= py-pyclamd and py-clamav dependencies are mutually exclusive. Run 'make config' to (re)configure ${PKGNAME}
-.endif
-
post-extract:
${MV} ${WRKSRC}/pythonfilter.conf ${WRKSRC}/pythonfilter.conf.sample
${MV} ${WRKSRC}/pythonfilter-modules.conf ${WRKSRC}/pythonfilter-modules.conf.sample
@@ -72,67 +74,67 @@ post-extract:
post-configure:
@${ECHO_MSG} Adding your OPTIONS to sample config file...
@${ECHO_MSG} >> ${WRKSRC}/pythonfilter.conf.sample
-.if !defined(WITHOUT_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
@${ECHO_MSG} debug >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_NODUPLICATES)
+.if ${PORT_OPTIONS:MNODUPLICATES}
@${ECHO_MSG} noduplicate >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_LOCALSENDERS)
+.if ${PORT_OPTIONS:MLOCALSENDERS}
@${ECHO_MSG} localsenders >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_CLAMAV_CLAMD) || defined(WITH_CLAMAV_LIB)
+.if ${PORT_OPTIONS:MCLAMAV_CLAMD) || ${PORT_OPTIONS:MCLAMAV_LIB}
@${ECHO_MSG} clamav >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_SPAMASSASSIN)
+.if ${PORT_OPTIONS:MSPAMASSASSIN}
@${ECHO_MSG} spamassassin >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_AUTO_WHITELIST)
+.if ${PORT_OPTIONS:MAUTO_WHITELIST}
@${ECHO_MSG} auto_whitelist >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if !defined(WITHOUT_WHITELIST_RELAY)
+.if ${PORT_OPTIONS:MWHITELIST_RELAY}
@${ECHO_MSG} whitelist_relayclients >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if !defined(WITHOUT_WHITELIST_AUTH)
+.if ${PORT_OPTIONS:MWHITELIST_AUTH}
@${ECHO_MSG} whitelist_auth >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_WHITELIST_BLOCK)
+.if ${PORT_OPTIONS:MWHITELIST_BLOCK}
@${ECHO_MSG} whitelist_block >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_WHITELIST_DNSWL)
+.if ${PORT_OPTIONS:MWHITELIST_DNSWL}
@${ECHO_MSG} whitelist_dnswl >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_WHITELIST_SPF)
+.if ${PORT_OPTIONS:MWHITELIST_SPF}
@${ECHO_MSG} whitelist_spf >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_DELIVEREDTO)
+.if ${PORT_OPTIONS:MDELIVEREDTO}
@${ECHO_MSG} deliveredto >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_PRIVATEADDR)
+.if ${PORT_OPTIONS:MPRIVATEADDR}
@${ECHO_MSG} privateaddr >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_SPFCHECK)
+.if ${PORT_OPTIONS:MSPFCHECK}
@${ECHO_MSG} spfcheck >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_NOSUCCESSDSN)
+.if ${PORT_OPTIONS:MNOSUCCESSDSN}
@${ECHO_MSG} nosuccessdsn >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_COMEAGAIN)
+.if ${PORT_OPTIONS:MCOMEAGAIN}
@${ECHO_MSG} comeagain >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_GREYLIST)
+.if ${PORT_OPTIONS:MGREYLIST}
@${ECHO_MSG} greylist >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_DIALBACK)
+.if ${PORT_OPTIONS:MDIALBACK}
@${ECHO_MSG} dialback >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_RATELIMIT)
+.if ${PORT_OPTIONS:MRATELIMIT}
@${ECHO_MSG} ratelimit >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_ATTACHMENTS)
+.if ${PORT_OPTIONS:MATTACHMENTS}
@${ECHO_MSG} attachments >> ${WRKSRC}/pythonfilter.conf.sample
.endif
-.if defined(WITH_QUOTA)
+.if ${PORT_OPTIONS:MQUOTA}
@${ECHO_MSG} quota >> ${WRKSRC}/pythonfilter.conf.sample
.endif
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 7410ddd251cd..bfb6c2ab6ab6 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
NO_BUILD= yes
PATCHDIR= /dev/null
-OPTIONS+= GDBM "Use gdbm instead of system bdb" off
+OPTIONS_DEFINE+= GDBM
.include "${.CURDIR}/Makefile.opt"
@@ -211,7 +211,7 @@ pre-install:
.endif # ${PKGNAMESUFFIX} == "-base"
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} ${_SHROWNGRP} -d ${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/security/courier-authlib/Makefile.dep b/security/courier-authlib/Makefile.dep
index af74c2d904b0..5238c4e7491d 100644
--- a/security/courier-authlib/Makefile.dep
+++ b/security/courier-authlib/Makefile.dep
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-authlib
-# Date created: 19 Dec 2004
-# Whom: Oliver Lehmann
-#
+# Created by: Oliver Lehmann
# $FreeBSD$
-#
# To depend on courier-authlib you might consider using this file by specifying
#
@@ -14,22 +10,22 @@
# in your Makefile *before* any
#.include <bsd.port.pre.mk>
-.if defined(WITH_AUTH_LDAP)
+.if ${PORT_OPTIONS:MAUTH_LDAP}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthldap.so:${PORTSDIR}/net/courier-authlib-ldap
.endif
-.if defined(WITH_AUTH_MYSQL)
+.if ${PORT_OPTIONS:MAUTH_MYSQL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthmysql.so:${PORTSDIR}/databases/courier-authlib-mysql
.endif
-.if defined(WITH_AUTH_PGSQL)
+.if ${PORT_OPTIONS:MAUTH_PGSQL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthpgsql.so:${PORTSDIR}/databases/courier-authlib-pgsql
.endif
-.if defined(WITH_AUTH_USERDB)
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MAUTH_USERDB}
+.if ${PORT_OPTIONS:MGDBM}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthuserdb.so:${PORTSDIR}/databases/courier-authlib-usergdbm
.else
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthuserdb.so:${PORTSDIR}/databases/courier-authlib-userdb
.endif
.endif
-.if defined(WITH_AUTH_VCHKPW)
+.if ${PORT_OPTIONS:MAUTH_VCHKPW}
BUILD_DEPENDS+= ${LOCALBASE}/lib/courier-authlib/libauthvchkpw.so:${PORTSDIR}/mail/courier-authlib-vchkpw
.endif
diff --git a/security/courier-authlib/Makefile.opt b/security/courier-authlib/Makefile.opt
index 38cc1f299c40..0b8175965af8 100644
--- a/security/courier-authlib/Makefile.opt
+++ b/security/courier-authlib/Makefile.opt
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-authlib
-# Date created: 19 Dec 2004
-# Whom: Oliver Lehmann
-#
+# Created by: Oliver Lehmann
# $FreeBSD$
-#
# To depend on courier-authlib you might consider using this file by specifying
#
@@ -14,8 +10,9 @@
# in your Makefile *after* any
#.include <bsd.port.pre.mk>
-OPTIONS+= AUTH_LDAP "LDAP support" off \
- AUTH_MYSQL "MySQL support" off \
- AUTH_PGSQL "PostgreSQL support" off \
- AUTH_USERDB "Userdb support" off \
- AUTH_VCHKPW "Vpopmail/vchkpw support" off
+OPTIONS_DEFINE+= AUTH_LDAP AUTH_MYSQL AUTH_PGSQL AUTH_USERDB AUTH_VCHKPW
+AUTH_LDAP_DESC= LDAP support
+AUTH_MYSQL_DESC= MySQL support
+AUTH_PGSQL_DESC= PostgreSQL support
+AUTH_USERDB_DESC= Userdb support
+AUTH_VCHKPW_DESC= popmail/vchkpw support