aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/darkice/Makefile17
-rw-r--r--audio/darkice/distinfo2
-rw-r--r--audio/darkice/files/patch-src_TcpSocket.cpp15
-rw-r--r--audio/darkice/pkg-comment2
4 files changed, 16 insertions, 20 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index b59d8700240e..8ecd148839d4 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= darkice
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,12 +17,23 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
vorbis.2:${PORTSDIR}/audio/libvorbis
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-lame-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
MAN1= darkice.1
MAN5= darkice.cfg.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 5000000
+USE_GCC= 3.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/audio/darkice/distinfo b/audio/darkice/distinfo
index 353f546632d2..8455d414da2a 100644
--- a/audio/darkice/distinfo
+++ b/audio/darkice/distinfo
@@ -1 +1 @@
-MD5 (darkice-0.11.tar.gz) = a5cf35c58bfe5eacd95ee991ce8feed2
+MD5 (darkice-0.12.tar.gz) = a28af863edaab12366a5b66b167b8fd6
diff --git a/audio/darkice/files/patch-src_TcpSocket.cpp b/audio/darkice/files/patch-src_TcpSocket.cpp
deleted file mode 100644
index 706c8ca7bee2..000000000000
--- a/audio/darkice/files/patch-src_TcpSocket.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- src/TcpSocket.cpp.orig Sat Jul 20 18:37:06 2002
-+++ src/TcpSocket.cpp Sat Aug 10 14:09:52 2002
-@@ -81,6 +81,9 @@
- #error need sys/time.h
- #endif
-
-+#ifndef MSG_NOSIGNAL
-+#define MSG_NOSIGNAL 0
-+#endif
-
- #include "Util.h"
- #include "Exception.h"
diff --git a/audio/darkice/pkg-comment b/audio/darkice/pkg-comment
index 274097213cce..3478295624dd 100644
--- a/audio/darkice/pkg-comment
+++ b/audio/darkice/pkg-comment
@@ -1 +1 @@
-DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer
+An IceCast, IceCast2 and ShoutCast live audio streamer
>-1/+1 * Add another 64-bit fix.jmz2008-07-222-1/+24 * Fix builds on 64-bit platformsjmz2008-07-212-1/+77 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-201-2/+2 * - Welcome X.org 7.2 \o/.flz2007-05-201-1/+1 * Remove man pages from plist as they are already listed in Makefile.jmz2006-06-061-4/+0 * Upgrade to version 4.1.16jmz2006-04-183-7/+10 * SHA256ifyedwin2006-01-241-0/+2 * Update to Debian revision 15.naddy2005-10-206-140/+10 * Update to 4.1-14.2jmz2005-08-302-2/+94 * Add size data.trevor2004-03-181-0/+2 * Unbreak for gcc-3.3 where #include <varargs.h> is a fatal error. varargspeter2003-10-231-0/+10 * Switch to MASTER_SITE_DEBIAN_POOLkris2003-08-041-2/+1 * Switch to MASTER_SITE_DEBIAN and convert COMMENT.naddy2003-02-132-3/+3 * Upgrade to revision 10.jmz2002-05-242-2/+2 * Set PREFIX so that pkg-install works well when the port is not installed injmz2001-10-092-2/+2 * Remove ftp.freesoftware.com from MASTER_SITES of ports since it no longer exi...dwcjr2001-09-241-2/+1 * Bump png majorache2001-09-111-1/+1 * Add USE_XLIB.jmz2001-07-271-3/+4 * Upgrade to version 4.1.9jmz2001-07-247-17/+139 * FIx a bug with the -tile option.jmz2001-06-232-0/+32