aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/tomcat-native/Makefile31
-rw-r--r--www/tomcat-native/distinfo3
-rw-r--r--www/tomcat-native/files/patch-Makefile.in16
-rw-r--r--www/tomcat-native/pkg-descr14
-rw-r--r--www/tomcat-native/pkg-plist4
6 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1cfc8f496d06..4698151e347b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1237,6 +1237,7 @@
SUBDIR += tikiwiki
SUBDIR += tinymce
SUBDIR += tinyproxy
+ SUBDIR += tomcat-native
SUBDIR += tomcat41
SUBDIR += tomcat55
SUBDIR += tomcat6
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
new file mode 100644
index 000000000000..e80ed2ff7342
--- /dev/null
+++ b/www/tomcat-native/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: tomcat-native
+# Date created: 28 Feb 2008
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tomcat-native
+PORTVERSION= 1.1.13
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= tomcat/tomcat-connectors/native
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Tomcat native library
+
+LIB_DEPENDS= apr-1.2:${PORTSDIR}/devel/apr
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/jni/native
+
+USE_OPENSSL= yes
+USE_JAVA= yes
+USE_LDCONFIG= yes
+JAVA_VERSION= 1.5+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-apr=${LOCALBASE} \
+ --with-java-home=${JAVA_HOME} \
+ --with-ssl=${SSLBASE}
+
+.include <bsd.port.mk>
diff --git a/www/tomcat-native/distinfo b/www/tomcat-native/distinfo
new file mode 100644
index 000000000000..2533e278557c
--- /dev/null
+++ b/www/tomcat-native/distinfo
@@ -0,0 +1,3 @@
+MD5 (tomcat-native-1.1.13-src.tar.gz) = 1bdf8b22eba97dc2f1fc25ed35a936cc
+SHA256 (tomcat-native-1.1.13-src.tar.gz) = 72cf681cb2a4c17f0fa612d258252d3b260529bdbda4b498718d56cdf64b55f0
+SIZE (tomcat-native-1.1.13-src.tar.gz) = 188391
diff --git a/www/tomcat-native/files/patch-Makefile.in b/www/tomcat-native/files/patch-Makefile.in
new file mode 100644
index 000000000000..5ff3072b21f5
--- /dev/null
+++ b/www/tomcat-native/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2008-02-28 15:08:20.000000000 +0100
++++ Makefile.in 2008-02-28 15:08:52.000000000 +0100
+@@ -67,12 +67,7 @@
+
+
+ install: $(TARGET_LIB)
+- $(APR_MKDIR) $(DESTDIR)$(includedir) $(DESTDIR)$(libdir)/pkgconfig \
+- $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+- $(INSTALL_DATA) tcnative.pc $(DESTDIR)$(libdir)/pkgconfig/$(TCNATIVE_PCFILE)
+- list='$(INSTALL_SUBDIRS)'; for i in $$list; do \
+- ( cd $$i ; $(MAKE) DESTDIR=$(DESTDIR) install ); \
+- done
++ $(APR_MKDIR) $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) -m 755 $(TARGET_LIB) $(DESTDIR)$(libdir)
+
+ $(TARGET_LIB): $(OBJECTS)
diff --git a/www/tomcat-native/pkg-descr b/www/tomcat-native/pkg-descr
new file mode 100644
index 000000000000..60aae72349d6
--- /dev/null
+++ b/www/tomcat-native/pkg-descr
@@ -0,0 +1,14 @@
+Tomcat can use the Apache Portable Runtime to provide superior scalability,
+performance, and better integration with native server technologies.
+APR has many uses, including access to advanced IO functionality (such as
+sendfile, epoll and OpenSSL), OS level functionality (random number
+generation, system status, etc), and native process handling (shared memory,
+NT pipes and Unix sockets).
+
+These features allows making Tomcat a general purposewebserver, will
+enable much better integration with other native web technologies, and
+overall make Java much more viable as a full fledged webserver platform
+rather than simply a backend focused technology.
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/www/tomcat-native/pkg-plist b/www/tomcat-native/pkg-plist
new file mode 100644
index 000000000000..0aabab203422
--- /dev/null
+++ b/www/tomcat-native/pkg-plist
@@ -0,0 +1,4 @@
+lib/libtcnative-1.a
+lib/libtcnative-1.la
+lib/libtcnative-1.so
+lib/libtcnative-1.so.1