aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pure-gl/Makefile37
-rw-r--r--graphics/pure-gl/distinfo2
-rw-r--r--graphics/pure-gl/pkg-descr6
-rw-r--r--graphics/pure-gl/pkg-plist8
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 38adf71c38af..bbbdcd4e8485 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -750,6 +750,7 @@
SUBDIR += projectm-libvisual
SUBDIR += pstoedit
SUBDIR += pstoepsi
+ SUBDIR += pure-gl
SUBDIR += pvmpov
SUBDIR += py-PyX
SUBDIR += py-aafigure
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
new file mode 100644
index 000000000000..133fdc82611d
--- /dev/null
+++ b/graphics/pure-gl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: pure-gtk
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-gl
+PORTVERSION= 0.8
+CATEGORIES= graphics
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure language interface to OpenGL
+
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure
+RUN_DEPENDS+= ${LOCALBASE}/lib/pure/ffi.pure:${PORTSDIR}/devel/pure-ffi
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GMAKE= yes
+USE_GL= glut
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib \
+ CFLAGS="${CFLAGS}" LinkGL="-lglut -lGLU -lGL"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/pure-gl/distinfo b/graphics/pure-gl/distinfo
new file mode 100644
index 000000000000..c9ab7b3a83f3
--- /dev/null
+++ b/graphics/pure-gl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-gl-0.8.tar.gz) = 7482dd04ae12a582f8bf05ef9d014c7e2af7aa03522f9edec4994420a6629340
+SIZE (pure-gl-0.8.tar.gz) = 166446
diff --git a/graphics/pure-gl/pkg-descr b/graphics/pure-gl/pkg-descr
new file mode 100644
index 000000000000..0fc1745d21ff
--- /dev/null
+++ b/graphics/pure-gl/pkg-descr
@@ -0,0 +1,6 @@
+pure-gl is Pure's interface to OpenGL, the well-known graphics library. It
+covers pretty much all of OpenGL, including the popular extensions.
+Extensions are loaded on demand, functions will throw an exception if they
+are not available in your OpenGL implementation.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-gl.html
diff --git a/graphics/pure-gl/pkg-plist b/graphics/pure-gl/pkg-plist
new file mode 100644
index 000000000000..e24cdec9f90e
--- /dev/null
+++ b/graphics/pure-gl/pkg-plist
@@ -0,0 +1,8 @@
+lib/pure/GL.pure
+lib/pure/GLU.pure
+lib/pure/GLUT.pure
+lib/pure/GL_ARB.pure
+lib/pure/GL_ATI.pure
+lib/pure/GL_EXT.pure
+lib/pure/GL_NV.pure
+lib/pure/pure-gl.so