aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/gpuzzle/Makefile26
-rw-r--r--games/gpuzzle/distinfo3
-rw-r--r--games/gpuzzle/pkg-descr9
-rw-r--r--games/gpuzzle/pkg-plist8
-rw-r--r--games/jigsaw/Makefile26
-rw-r--r--games/jigsaw/distinfo3
-rw-r--r--games/jigsaw/pkg-descr9
-rw-r--r--games/jigsaw/pkg-plist8
9 files changed, 93 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 65d4db915b30..8921c24ae988 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -278,6 +278,7 @@
SUBDIR += golddig
SUBDIR += gomoku.app
SUBDIR += goonies
+ SUBDIR += gpuzzle
SUBDIR += gracer
SUBDIR += grande
SUBDIR += greed
diff --git a/games/gpuzzle/Makefile b/games/gpuzzle/Makefile
new file mode 100644
index 000000000000..627723545b92
--- /dev/null
+++ b/games/gpuzzle/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gpuzzle
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpuzzle
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://www.gnustep.it/marko/GPuzzle2/
+DISTNAME= GPuzzle2
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Simulates a jigsaw puzzle and illustrates the use of clipping paths
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+
+.include <bsd.port.mk>
diff --git a/games/gpuzzle/distinfo b/games/gpuzzle/distinfo
new file mode 100644
index 000000000000..5f249703b2c8
--- /dev/null
+++ b/games/gpuzzle/distinfo
@@ -0,0 +1,3 @@
+MD5 (GPuzzle2.tgz) = 5b162eedcc021941d2d3987b3a67cc47
+SHA256 (GPuzzle2.tgz) = 47086916b3818fe7c3dacc5bc80c0ffb076f2ba8c9055737a5524453ba627ef1
+SIZE (GPuzzle2.tgz) = 35679
diff --git a/games/gpuzzle/pkg-descr b/games/gpuzzle/pkg-descr
new file mode 100644
index 000000000000..0477d9ed798a
--- /dev/null
+++ b/games/gpuzzle/pkg-descr
@@ -0,0 +1,9 @@
+Simulates a jigsaw puzzle and illustrates the use of clipping paths.
+
+You need a medium-sized TIFF file to play this game.
+Left-click and drag to move a piece or cluster.
+Ctrl-left-click and drag to connect knobs to slots.
+Right-click to disassemble a cluster.
+Ctrl-right-click to extract a piece from a cluster.
+
+WWW: http://www.gnustep.it/marko/GPuzzle2/
diff --git a/games/gpuzzle/pkg-plist b/games/gpuzzle/pkg-plist
new file mode 100644
index 000000000000..4015497cc611
--- /dev/null
+++ b/games/gpuzzle/pkg-plist
@@ -0,0 +1,8 @@
+Local/Applications/GPuzzle2.app/GPuzzle2
+Local/Applications/GPuzzle2.app/Resources/GPuzzle2.desktop
+Local/Applications/GPuzzle2.app/Resources/GPuzzle2.tiff
+Local/Applications/GPuzzle2.app/Resources/Info-gnustep.plist
+Local/Applications/GPuzzle2.app/library_paths.openapp
+Local/Applications/GPuzzle2.app/stamp.make
+@dirrm Local/Applications/GPuzzle2.app/Resources
+@dirrm Local/Applications/GPuzzle2.app
diff --git a/games/jigsaw/Makefile b/games/jigsaw/Makefile
new file mode 100644
index 000000000000..627723545b92
--- /dev/null
+++ b/games/jigsaw/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gpuzzle
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gpuzzle
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://www.gnustep.it/marko/GPuzzle2/
+DISTNAME= GPuzzle2
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Simulates a jigsaw puzzle and illustrates the use of clipping paths
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+
+.include <bsd.port.mk>
diff --git a/games/jigsaw/distinfo b/games/jigsaw/distinfo
new file mode 100644
index 000000000000..5f249703b2c8
--- /dev/null
+++ b/games/jigsaw/distinfo
@@ -0,0 +1,3 @@
+MD5 (GPuzzle2.tgz) = 5b162eedcc021941d2d3987b3a67cc47
+SHA256 (GPuzzle2.tgz) = 47086916b3818fe7c3dacc5bc80c0ffb076f2ba8c9055737a5524453ba627ef1
+SIZE (GPuzzle2.tgz) = 35679
diff --git a/games/jigsaw/pkg-descr b/games/jigsaw/pkg-descr
new file mode 100644
index 000000000000..0477d9ed798a
--- /dev/null
+++ b/games/jigsaw/pkg-descr
@@ -0,0 +1,9 @@
+Simulates a jigsaw puzzle and illustrates the use of clipping paths.
+
+You need a medium-sized TIFF file to play this game.
+Left-click and drag to move a piece or cluster.
+Ctrl-left-click and drag to connect knobs to slots.
+Right-click to disassemble a cluster.
+Ctrl-right-click to extract a piece from a cluster.
+
+WWW: http://www.gnustep.it/marko/GPuzzle2/
diff --git a/games/jigsaw/pkg-plist b/games/jigsaw/pkg-plist
new file mode 100644
index 000000000000..4015497cc611
--- /dev/null
+++ b/games/jigsaw/pkg-plist
@@ -0,0 +1,8 @@
+Local/Applications/GPuzzle2.app/GPuzzle2
+Local/Applications/GPuzzle2.app/Resources/GPuzzle2.desktop
+Local/Applications/GPuzzle2.app/Resources/GPuzzle2.tiff
+Local/Applications/GPuzzle2.app/Resources/Info-gnustep.plist
+Local/Applications/GPuzzle2.app/library_paths.openapp
+Local/Applications/GPuzzle2.app/stamp.make
+@dirrm Local/Applications/GPuzzle2.app/Resources
+@dirrm Local/Applications/GPuzzle2.app