aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/rox-archive/Makefile33
-rw-r--r--archivers/rox-archive/distinfo1
-rw-r--r--archivers/rox-archive/pkg-descr4
-rw-r--r--archivers/rox-archive/pkg-plist21
5 files changed, 60 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 69bedcc1a07a..5b265c66c9ad 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -43,6 +43,7 @@
SUBDIR += py-bzip2
SUBDIR += py-tarfile
SUBDIR += rar
+ SUBDIR += rox-archive
SUBDIR += rpm
SUBDIR += rpm2cpio
SUBDIR += ruby-bz2
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
new file mode 100644
index 000000000000..27bb27ddb003
--- /dev/null
+++ b/archivers/rox-archive/Makefile
@@ -0,0 +1,33 @@
+# Ports collection Makefile for: rox-archive
+# Date created: Mar 24 2003
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rox-archive
+PORTVERSION= 1.9.1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rox
+DISTNAME= archive-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Archive management tool for the ROX desktop
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
+ ${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
+
+USE_PYTHON= yes
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/apps
+ @${CP} -r ${WRKSRC}/Archive ${PREFIX}/apps/
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/apps/Archive
+
+.include <bsd.port.mk>
diff --git a/archivers/rox-archive/distinfo b/archivers/rox-archive/distinfo
new file mode 100644
index 000000000000..2d875272a8c7
--- /dev/null
+++ b/archivers/rox-archive/distinfo
@@ -0,0 +1 @@
+MD5 (archive-1.9.1.tgz) = d3d2565c04e7209af5f4f9c81094f4b4
diff --git a/archivers/rox-archive/pkg-descr b/archivers/rox-archive/pkg-descr
new file mode 100644
index 000000000000..2f1ebab361c1
--- /dev/null
+++ b/archivers/rox-archive/pkg-descr
@@ -0,0 +1,4 @@
+Archive management tool for the ROX desktop, supporting a variety
+of file formats.
+
+WWW: http://rox.sourceforge.net/archive.php3
diff --git a/archivers/rox-archive/pkg-plist b/archivers/rox-archive/pkg-plist
new file mode 100644
index 000000000000..19658e37aef4
--- /dev/null
+++ b/archivers/rox-archive/pkg-plist
@@ -0,0 +1,21 @@
+apps/Archive/.DirIcon
+apps/Archive/AppInfo.xml
+apps/Archive/AppRun
+apps/Archive/Help/COPYING
+apps/Archive/Help/Changes
+apps/Archive/Help/README
+apps/Archive/box.py
+apps/Archive/box.pyc
+apps/Archive/box.pyo
+apps/Archive/findrox.py
+apps/Archive/findrox.pyc
+apps/Archive/findrox.pyo
+apps/Archive/formats.py
+apps/Archive/formats.pyc
+apps/Archive/formats.pyo
+apps/Archive/support.py
+apps/Archive/support.pyc
+apps/Archive/support.pyo
+@dirrm apps/Archive/Help
+@dirrm apps/Archive
+@unexec rmdir %D/apps 2>/dev/null || true
+33 * Cleanup plistsantoine2018-10-011-13/+13 * sysutils/javaservicewrapper: pet portlintjmd2018-10-012-14/+21 * The updated libgtop included in the GNOME 3.28 update broke runtime forkwm2018-10-015-5/+5 * Update to 1.4.1sunpoet2018-10-012-4/+5 * The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.kwm2018-09-3043-960/+896 * Bump PORTREVISION to chase update of multimedia/v4l_compat and libv4lriggs2018-09-291-1/+1 * - Update to 0.29.0danilo2018-09-292-18/+6 * lang/rust: update to 1.29.1jbeich2018-09-294-3/+4 * - Update to 1.12.0danilo2018-09-292-4/+4 * Fix build when EXAMPLES is setromain2018-09-281-1/+0 * Add an option for GeoIP2 database support via libmaxminddbadamw2018-09-281-2/+9 * Update to 3.0.2romain2018-09-282-6/+7 * Update to 1.1.1romain2018-09-283-8/+8 * - Add LICENSEamdmi32018-09-282-1/+3 * sysutils/potnet: Add LICENSE_FILE.0mp2018-09-281-0/+1 * Fix build on gcc-based archs.linimon2018-09-281-4/+3 * sysutils/potnet: New port.pizzamig2018-09-284-0/+140 * Update to 20180927.jkim2018-09-282-4/+4 * Deprecate a bunch of MCollective related portsromain2018-09-275-0/+10 * - Add UPOWER option to xfce4-systemload-plugin, enabled by defaultmadpilot2018-09-271-5/+9 * Update to latest releaseromain2018-09-273-19/+4 * New port: sysutils/puppetserver6romain2018-09-2716-0/+369 * New port: sysutils/puppet6romain2018-09-2710-2/+231 * New port: sysutils/rubygem-puppetserver-caromain2018-09-275-0/+51 * Install the generated .gemspec fileromain2018-09-272-0/+6 * Update to 0.21.0.vanilla2018-09-272-7/+7 * sysutils/coreutils: update to 8.30fernape2018-09-272-13/+14 * Update Objective-C LLVM version to 6.0.brooks2018-09-262-2/+2 * Fix error messages on tier-2 archs.linimon2018-09-261-3/+3 * Update to the latest cfengine github commit.cy2018-09-265-12/+10 * - Update to 2.11.0danilo2018-09-263-6/+6 * bump llvm depend for 10.x to llvm60.brooks2018-09-261-3/+3 * - Update to 0.1.3danilo2018-09-262-4/+4 * sysutils/tuptime: update to 3.4.0fernape2018-09-264-24/+30 * sysutils/bfs: Update to 1.2.4tobik2018-09-252-5/+8 * sysutils/slurm-wlm: Change WWW to httpsyuri2018-09-251-1/+1 * Mark BROKEN on FreeBSD 12kmoore2018-09-251-0/+2 * - Update to 2018.3.2wen2018-09-243-5/+15 * Update to 2.0.42.mat2018-09-247-17/+16 * sysutils/s-tui: Update 0.6.7.4 -> 0.8.2yuri2018-09-243-10/+16 * update sysutils/packer to 1.3.1lifanov2018-09-242-4/+4 * update sysutils/ansible25 to 2.5.9lifanov2018-09-242-4/+4 * New port: sysutils/bfstobik2018-09-234-0/+42 * Change URL in pkg-descr to use https.madpilot2018-09-231-1/+1 * Update xfce4-battery-plugin to 1.1.1madpilot2018-09-233-4/+5 * Require a modern compiler, this should fix build on powerpc64antoine2018-09-231-3/+1 * Update to 0.2.1sunpoet2018-09-232-6/+7 * Attempt to fix build on powerpc64.mandree2018-09-221-4/+6 * Update to 8.38.0matthew2018-09-222-5/+4 * - Update to 3.3.4wen2018-09-227-143/+35 * sysutils/ipfs-go: Switch to upstream-provided source tarballyuri2018-09-222-22/+12 * Update to 1.16.5sunpoet2018-09-222-6/+7 * sysutils/ganglia-webfrontend: Fix known display bug in cluster viewjwb2018-09-212-2/+13 * Update to 3.12.0romain2018-09-212-4/+4 * sysutils/tarsnap-gui: update to 1.0.2swills2018-09-212-5/+4 * - take maintainershipdinoex2018-09-201-1/+1 * Update to 3.4.5sunpoet2018-09-202-4/+4 * sysutils/storcli: Update to 7.709swills2018-09-202-7/+7 * sysutils/xorriso: update to 1.5.0swills2018-09-194-10/+40 * sysutils/s6: update to 2.7.2.0fernape2018-09-193-12/+18 * sysutils/reggae: Update to 0.1.0swills2018-09-193-4/+18 * u-boot: Update to v2018.09manu2018-09-182-4/+4 * Add gnu99 to USE_CSTD to fix builds on gcc-based archs.linimon2018-09-181-0/+1 * sysutils/consul: update to 1.2.3swills2018-09-182-4/+4 * sysutils/py-filelock: Update 3.0.6 -> 3.0.8yuri2018-09-182-4/+4 * Update KDE Frameworks to 5.50tcberner2018-09-184-6/+12 * Deprecate ports that do not build on FreeBSD 11+antoine2018-09-162-0/+4 * sysutils/py-dirsync: update to 2.2.3 and install LICENSE textrene2018-09-162-5/+8 * Update to 1.4.2sunpoet2018-09-162-4/+4 * Update to 1.7.4sunpoet2018-09-162-4/+5 * Update to 3.2sunpoet2018-09-164-72/+25 * Update to 11.4sunpoet2018-09-162-4/+4 * sysutils/x86info: pick up latest sources.ler2018-09-164-49/+6 * sysutils/runit-faster: Update scripts to 0.1.26tobik2018-09-153-4/+5 * Update WWWsunpoet2018-09-151-1/+1 * Update WWWsunpoet2018-09-151-1/+1 * Update WWWsunpoet2018-09-151-1/+1 * Update WWWsunpoet2018-09-151-1/+1 * - Use GO_* variables to simplify the Makefiledanilo2018-09-141-26/+22 * - Use GO_* variables to simplify the Makefiledanilo2018-09-141-11/+6 * sysutils/vagrant: update to 2.1.5cmt2018-09-144-7/+9 * - Set the commit hash of this release to fix a runtime panic in the command "...danilo2018-09-131-0/+2 * - Add LICENSEamdmi32018-09-132-1/+3 * - Update to 0.1.2danilo2018-09-132-5/+6 * New port sysutils/lxqt-adminjsm2018-09-134-0/+34 * sysutils/javaservicewrapper: require at least Java8jmd2018-09-121-2/+2 * - Update to 1.11.3danilo2018-09-122-17/+9 * Change x11/xorgproto to become a build depzeising2018-09-124-4/+4 * sysutils/android-file-transfer: update to 3.5jbeich2018-09-112-5/+5 * There is no need to remove .orig files.des2018-09-101-3/+0 * Various cleanup & fixes post-DOCS/EXAMPLES cleanup.mat2018-09-101-2/+0 * Add EXAMPLES options to ports that should have one.mat2018-09-106-4/+8 * Add DOCS options to ports that should have one.mat2018-09-1056-14/+108 * After an include, PLIST_SUB must be appended to, not overwritten.mat2018-09-101-2/+2 * Regenerate with 'make makepatch'.des2018-09-101-9/+9 * Reassign all of tobez@'s p5 ports to perl@.des2018-09-104-4/+4 * - Add LICENSEamdmi32018-09-102-2/+4 * xen-tools411: re-add markdownroyger2018-09-102-20/+2 * - Update to 0.1.20180813ehaupt2018-09-103-6/+9 * Remove trailing space.des2018-09-101-1/+1 * update sysutils/ansible to 2.6.4lifanov2018-09-102-4/+4 * update sysutils/debootstrap to 1.0.109lifanov2018-09-102-4/+4 * Mark various ports broken on powerpc64.linimon2018-09-101-0/+2 * - Add LICENSEamdmi32018-09-091-0/+3 * New port: sysutils/yanktobik2018-09-095-0/+44 * - Update to 1.0.2danilo2018-09-083-19/+12 * sysutils/smenu: Update to 0.9.14dbaio2018-09-082-4/+4 * sysutils/smartmontools: unbreak in 12-CURRENTfernape2018-09-071-1/+1 * Fix service munin-asyncd status.mat2018-09-072-3/+2 * sysutils/lockfile-progs: Update to 0.1.18swills2018-09-073-6/+6 * Update to 1.4.1sunpoet2018-09-072-7/+6 * Update the current KDE Applications to 18.08.1, the latest release.adridg2018-09-0714-40/+40 * sysutils/pcapfix: update to 1.1.3swills2018-09-072-4/+4 * Update to the latest cfengine commit on github.cy2018-09-066-10/+12 * Remove an extraneous blank line.cy2018-09-061-1/+0 * archivers/libunrar5: Update to 5.6.6jhale2018-09-061-1/+1 * Update to 10.2+0.94+2jhale2018-09-062-6/+9 * Update to 0.16.0sunpoet2018-09-062-4/+4 * Update devel/json-c to 0.13.1sunpoet2018-09-0613-10/+13 * xen-tools411: remove markdown and pandoc DOCS dependencyroyger2018-09-061-3/+1 * - Update to 2018.08.11nivit2018-09-052-5/+8 * sysutils/npadmin: Fix build with Clang 6tobik2018-09-041-0/+4 * sysutils/py-hpilo: Update to 4.3pizzamig2018-09-042-4/+4 * sysutils/dsbmc: Corrections to previous commitswills2018-09-031-2/+1 * Update to 2.0.40.mat2018-09-035-19/+11 * sysutils/intel-pcm-devel: update to g20180717swills2018-09-032-7/+8 * - Update to 0.1.1danilo2018-09-034-72/+7 * sysutils/dsbmd: update to 1.5swills2018-09-032-4/+4 * sysutils/dsbmc: update to 0.5swills2018-09-032-5/+6 * sysutils/dsbmc-cli: update to 0.2swills2018-09-032-4/+4 * Fix build on FreeBSD 10.4dvl2018-09-022-0/+14 * Second try at fixing linking problems with the OPENSSL option is selected.matthew2018-09-021-2/+2 * Update to 1.3.0sunpoet2018-09-022-4/+4 * Update to 1.6.2sunpoet2018-09-027-14/+54 * Mark BROKEN: fails to buildantoine2018-09-021-0/+2 * u-boot: Re-add cache patchesmanu2018-09-024-1/+42 * Switch default version of samba to 4.7antoine2018-09-025-2/+5 * - clariftamdmi32018-09-012-2/+3 * Fix ezjail use of make distribution and the path to snapshots on the mirrors.brd2018-09-012-0/+21 * sysutils/py-filelock: Update 3.0.4 -> 3.0.6yuri2018-08-312-4/+4 * sysutils/google-compute-engine-oslogin: Unbreak buildyuri2018-08-312-3/+22 * sysutils/ipfs-go: Update 0.4.15 -> 0.4.17yuri2018-08-314-23/+73 * Deprecate KDE4 software in categories graphics-textproc.adridg2018-08-3117-0/+51 * Update `sysutils/avfs' to version 1.0.6.danfe2018-08-302-4/+4 * Update sysutils/webmin to version 1.890.olgeni2018-08-30