aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/opal3/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index d5ff98f5207f..a6af2f95bf09 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opal3
PORTVERSION= 3.6.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF/opalvoip/v3.6%20Lalande/Stable%205
DISTNAME= opal-${PORTVERSION}
@@ -68,7 +68,7 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} \
.if defined(WITH_ZRTP)
.if !defined(SAFE_ZRTP)
-IGNORE= Please build devel/libzrtpcpp WITHOUT ports SSL and re-run build with SAFE_ZRTP set
+IGNORE= please build devel/libzrtpcpp WITHOUT ports SSL and re-run build with SAFE_ZRTP set
.endif
LIB_DEPENDS+= zrtpcpp.0:${PORTSDIR}/devel/libzrtpcpp
CONFIGURE_ARGS+= --enable-zrtp
@@ -266,4 +266,7 @@ post-patch:
@${REINPLACE_CMD} -e 's/^\(all:\).*/\1 optdepend opt/' ${WRKSRC}/Makefile.in
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's?\$$(LIB_FILENAME_SHARED_PAT)?libopal-${PORTVERSION:C/.[0-9]+$//g}'.so.'${PORTVERSION:C/^[0-9]+.[0-9]+.//}?' ${WRKSRC}/opal_defs.mak
+
.include <bsd.port.post.mk>