aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/curvedns/Makefile36
-rw-r--r--dns/dnscrypt-proxy/Makefile2
-rw-r--r--net-im/tox/Makefile1
-rw-r--r--net/libzmq4/Makefile2
-rw-r--r--security/libsodium/Makefile14
-rw-r--r--security/libsodium/pkg-plist4
6 files changed, 28 insertions, 31 deletions
diff --git a/dns/curvedns/Makefile b/dns/curvedns/Makefile
index 24f7056639e4..f7748489df6c 100644
--- a/dns/curvedns/Makefile
+++ b/dns/curvedns/Makefile
@@ -1,14 +1,19 @@
# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
# $FreeBSD$
-PORTNAME= curvedns
-PORTVERSION= 0.88.b
-PORTREVISION= 3
-CATEGORIES= dns
-DISTNAME= curvedns-0.88-unstable
+PORTNAME= curvedns
+PORTVERSION= 0.88.b
+PORTREVISION= 4
+CATEGORIES= dns
+DISTNAME= curvedns-0.88-unstable
MAINTAINER= vsevolod@FreeBSD.org
-COMMENT= Forwarder adding DNSCurve to an authoritative nameserver
+COMMENT= Forwarder adding DNSCurve to an authoritative nameserver
+
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
+ libsodium.so:${PORTSDIR}/security/libsodium
+RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_GITHUB= yes
GH_ACCOUNT= vstakhov
@@ -17,22 +22,15 @@ GH_COMMIT= a88e27e
ALL_TARGET= targets
-LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
- libsodium.so:${PORTSDIR}/security/libsodium
-RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USERS= bind
-GROUPS= bind
-CURVE_UID= 53
-CURVE_GID= 53
-
-SUB_FILES= pkg-message
+USERS= bind
+GROUPS= bind
+CURVE_UID= 53
+CURVE_GID= 53
-.include <bsd.port.pre.mk>
+SUB_FILES= pkg-message
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/curvedns ${WRKSRC}/curvedns-keygen ${STAGEDIR}${PREFIX}/bin/
@@ -43,4 +41,4 @@ do-install:
${ECHO_CMD} ${CURVE_GID} > ${STAGEDIR}${PREFIX}/etc/curvedns/env/GID
${CHMOD} 0700 ${STAGEDIR}${PREFIX}/etc/curvedns/env
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/dnscrypt-proxy/Makefile b/dns/dnscrypt-proxy/Makefile
index f51b53c4e276..a42e0cf9cd57 100644
--- a/dns/dnscrypt-proxy/Makefile
+++ b/dns/dnscrypt-proxy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dnscrypt-proxy
PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://download.dnscrypt.org/dnscrypt-proxy/ \
http://www.dns-lab.com/downloads/dnscrypt-proxy/
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index 7cb77a9e1064..83de6ba0ed60 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= toxcore
PORTVERSION= 0.140630
+PORTREVISION= 1
CATEGORIES= net-im net-p2p
MAINTAINER= thierry@FreeBSD.org
diff --git a/net/libzmq4/Makefile b/net/libzmq4/Makefile
index bb0f5741c653..6d417d484537 100644
--- a/net/libzmq4/Makefile
+++ b/net/libzmq4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libzmq4
PORTVERSION= 4.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://download.zeromq.org/
DISTNAME= zeromq-${DISTVERSION}
diff --git a/security/libsodium/Makefile b/security/libsodium/Makefile
index 7449680d7399..f0ee5d27425e 100644
--- a/security/libsodium/Makefile
+++ b/security/libsodium/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libsodium
PORTVERSION= 0.4.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://download.dnscrypt.org/libsodium/releases/
@@ -11,22 +12,19 @@ COMMENT= Library to build higher-level cryptographic tools
LICENSE= ISCL
GNU_CONFIGURE= yes
+USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
-USES= pkgconfig
OPTIONS_DEFINE= DOCS
PORTDOCS= AUTHORS README.markdown THANKS
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
-
-post-build:
- cd ${WRKSRC} && ${MAKE} check
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
+regression-test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check)
+
.include <bsd.port.mk>
diff --git a/security/libsodium/pkg-plist b/security/libsodium/pkg-plist
index aaebe3d0a220..326d09c51be8 100644
--- a/security/libsodium/pkg-plist
+++ b/security/libsodium/pkg-plist
@@ -51,8 +51,8 @@ include/sodium/randombytes_sysrandom.h
include/sodium/utils.h
include/sodium/version.h
lib/libsodium.a
-lib/libsodium.la
lib/libsodium.so
-lib/libsodium.so.9
+lib/libsodium.so.4
+lib/libsodium.so.4.5.0
libdata/pkgconfig/libsodium.pc
@dirrmtry include/sodium