aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/p5-Apache-Peek/Makefile16
-rw-r--r--www/p5-Apache-Peek/pkg-descr12
2 files changed, 21 insertions, 7 deletions
diff --git a/www/p5-Apache-Peek/Makefile b/www/p5-Apache-Peek/Makefile
index fd0a6a028ac3..a868f11a65a6 100644
--- a/www/p5-Apache-Peek/Makefile
+++ b/www/p5-Apache-Peek/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=Apache
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= skv@FreeBSD.org
COMMENT= A data debugging tool for the XS programmer (under mod_perl)
.if defined(WITH_MODPERL2)
@@ -23,7 +23,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
MOD_PERL= 1
.endif
-RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
@@ -31,4 +30,15 @@ CONFIGURE_ARGS= -httpd ${LOCALBASE}/sbin/httpd
MAN3= Apache::Peek.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Devel/Peek.pm:${PORTSDIR}/devel/p5-Devel-Peek
+.endif
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+post-patch:
+ @${PERL} -pi -e '$$_="" if /^test_configure\(/;' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Peek/pkg-descr b/www/p5-Apache-Peek/pkg-descr
index 6fcb2fd3be9e..b65f1c9df97b 100644
--- a/www/p5-Apache-Peek/pkg-descr
+++ b/www/p5-Apache-Peek/pkg-descr
@@ -1,6 +1,10 @@
-A data debugging tool for the XS programmer (under mod_perl)
+Apache::Peek is a data debugging tool for the XS programmer (under
+mod_perl).
-WWW: http://stason.org
+Apache::Peek is a sub-class of Devel::Peek. The only difference is that
+it overrides the stderr stream, to which Devel::Peek sends its output,
+and send the output to the client instead.
-- Leo Kim
-leo@florida.sarang.net
+Apache::Peek works both with mod_perl 1.0 and 2.0.
+
+WWW: http://search.cpan.org/dist/Apache-Peek/