aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/qnetchess/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/qnetchess/Makefile b/games/qnetchess/Makefile
index d7fe34f23515..7e23c0a45eea 100644
--- a/games/qnetchess/Makefile
+++ b/games/qnetchess/Makefile
@@ -25,6 +25,10 @@ MAKE_ARGS+= LOCALE_FILE="${LOCALE_FILE}" QTDIR="${QT_PREFIX}"
PLIST_FILES= bin/QNetChess %%DATADIR%%/${PORTNAME}_ru.qm
PLIST_DIRS= %%DATADIR%%
+post-patch:
+ ${REINPLACE_CMD} -e 's|static char|static const char|' \
+ ${WRKSRC}/xpm/*
+
do-install:
${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/QNetChess ${PREFIX}/bin