aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/xlog/Makefile4
-rw-r--r--net/libunp/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/comms/xlog/Makefile b/comms/xlog/Makefile
index c2fdb72bc039..f96219e8b36c 100644
--- a/comms/xlog/Makefile
+++ b/comms/xlog/Makefile
@@ -19,6 +19,10 @@ MAN1= xlog.1
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Does not compile on alpha 4.x"
+.endif
+
.if defined(WITH_HAMLIB)
LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib
CONFIGURE_ARGS+= --enable-hamlib
diff --git a/net/libunp/Makefile b/net/libunp/Makefile
index 14e8d1ed4a68..a6a822087cdc 100644
--- a/net/libunp/Makefile
+++ b/net/libunp/Makefile
@@ -21,6 +21,10 @@ USE_GMAKE= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Does not compile on alpha 4.x"
+.endif
+
pre-patch:
@ ${CP} ${WRKSRC}/lib/wrapsock.c ${WRKSRC}/lib/wrapsock_r.c