aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/samba34/Makefile2
-rw-r--r--net/samba34/files/samba.in9
2 files changed, 9 insertions, 2 deletions
diff --git a/net/samba34/Makefile b/net/samba34/Makefile
index caf83ee9ab87..09dbf7538c95 100644
--- a/net/samba34/Makefile
+++ b/net/samba34/Makefile
@@ -7,7 +7,7 @@
PORTNAME= samba34
PORTVERSION= 3.4.9
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= . old-versions rc pre
diff --git a/net/samba34/files/samba.in b/net/samba34/files/samba.in
index e955b72f576a..cb86f976ea5f 100644
--- a/net/samba34/files/samba.in
+++ b/net/samba34/files/samba.in
@@ -137,7 +137,7 @@ samba_reload_cmd() {
}
samba_cmd() {
- local name rcvar command pidfile samba_daemons
+ local name rcvar command pidfile samba_daemons result _result
# Prevent recursive calling
unset "${rc_arg}_cmd" "${rc_arg}_precmd" "${rc_arg}_postcmd"
# Stop processes in the reverse to order
@@ -145,6 +145,7 @@ samba_cmd() {
samba_daemons=$(reverse_list ${samba_daemons})
fi
# Apply to all daemons
+ result=0
for name in ${samba_daemons}; do
rcvar=$(set_rcvar)
command="%%PREFIX%%/sbin/${name}"
@@ -152,8 +153,14 @@ samba_cmd() {
# Daemon should be enabled and running
if [ -n "${rcvar}" ] && checkyesno "${rcvar}"; then
run_rc_command "${_rc_prefix}${rc_arg}" ${rc_extra_args}
+ # Collect return values
+ _result=$?
+ if [ ${_result} != 0 ]; then
+ result=${_result}
+ fi
fi
done
+ return $result
}
run_rc_command "$1"
ceForge ports to the new File Release System: categories startin...amdmi32009-08-221-1/+1 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-1/+1 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * - Chase multimedia/mplayer splitrafan2007-08-111-1/+1 * - Welcome X.org 7.2 \o/.flz2007-05-202-2/+1 * Remove support for swt31 and add support for swt or optional swt-develahze2007-02-211-7/+23