aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/pim6dd/Makefile27
-rw-r--r--net/pim6dd/distinfo1
-rw-r--r--net/pim6dd/pkg-comment1
-rw-r--r--net/pim6dd/pkg-descr2
-rw-r--r--net/pim6dd/pkg-plist1
6 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 671bae241053..28b9b5e4783e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -276,6 +276,7 @@
SUBDIR += pdnsd
SUBDIR += perldap
SUBDIR += pfinger
+ SUBDIR += pim6dd
SUBDIR += pipsecd
SUBDIR += pmf
SUBDIR += poptop
diff --git a/net/pim6dd/Makefile b/net/pim6dd/Makefile
new file mode 100644
index 000000000000..5dbf5ec23b35
--- /dev/null
+++ b/net/pim6dd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pim6-sd
+# Date created: 2 Jun 2001
+# Whom: dwcjr
+#
+# $FreeBSD$
+#
+
+PORTNAME= pim6dd
+PORTVERSION= 20010602a
+CATEGORIES= net ipv6
+MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
+
+MAINTAINER= ume@FreeBSD.org
+
+MAN5= pim6dd.conf.5
+MAN8= pim6dd.8
+MANCOMPRESSED= yes
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+post-patch:
+.for file in Makefile.inc pim6dd/pathnames.h pim6dd/pim6dd.8
+ @${PERL} -pi.orig -e 's./usr/local/v6.${PREFIX}.g' ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/pim6dd/distinfo b/net/pim6dd/distinfo
new file mode 100644
index 000000000000..c0c9ffce8958
--- /dev/null
+++ b/net/pim6dd/distinfo
@@ -0,0 +1 @@
+MD5 (pim6dd-20010602a.tar.gz) = a995d3321fa369a9ee6fc4dff75cabe3
diff --git a/net/pim6dd/pkg-comment b/net/pim6dd/pkg-comment
new file mode 100644
index 000000000000..8bdd06bbc9fc
--- /dev/null
+++ b/net/pim6dd/pkg-comment
@@ -0,0 +1 @@
+PIM for IPv6 dense mode daemon
diff --git a/net/pim6dd/pkg-descr b/net/pim6dd/pkg-descr
new file mode 100644
index 000000000000..004a9bac1131
--- /dev/null
+++ b/net/pim6dd/pkg-descr
@@ -0,0 +1,2 @@
+Pim6dd is an IPv6 multicast routing daemon, which supports PIMv2
+(Protocol Independent Multicast Version 2) dense mode for IPv6.
diff --git a/net/pim6dd/pkg-plist b/net/pim6dd/pkg-plist
new file mode 100644
index 000000000000..d7551775780c
--- /dev/null
+++ b/net/pim6dd/pkg-plist
@@ -0,0 +1 @@
+sbin/pim6dd