aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/xfce4-mixer/Makefile9
-rw-r--r--print/xfce4-print/Makefile4
-rw-r--r--x11-wm/xfce4-desktop/Makefile6
-rw-r--r--x11-wm/xfce4-session/Makefile5
4 files changed, 17 insertions, 7 deletions
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
index dd076445d989..892f2c4ee159 100644
--- a/audio/xfce4-mixer/Makefile
+++ b/audio/xfce4-mixer/Makefile
@@ -17,12 +17,15 @@ DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 volume mixer module for xfce4-panel
-BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
xml2.5:${PORTSDIR}/textproc/libxml2 \
- startup-notification-1.0:${PORTSDIR}/x11/startup-notification
-RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
+ xfce4mcs-client.2:${PORTSDIR}/x11/libxfce4mcs
+RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GETTEXT= yes
USE_GNOME= gtk20
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index d2c436f13d02..e0ae7f6a5062 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -18,8 +18,10 @@ DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 graphical frontend for printing
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
- xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
+ xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui \
+RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
USE_GETTEXT= yes
USE_GNOME= gtk20
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index eae10c2d6d91..cc33a3f26d6e 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -18,11 +18,13 @@ DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 desktop background manager and root menu
-BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
-RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
+RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GETTEXT= yes
USE_GNOME= gtk20
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index d3902f6ff127..df045fb6ce51 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -17,9 +17,12 @@ DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= Session manager for the Xfce 4 desktop environment
-BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ iceauth:${X_CLIENTS_PORT}
LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.3:${PORTSDIR}/x11-toolkits/libxfce4gui
+RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager \
+ iceauth:${X_CLIENTS_PORT}
USE_X_PREFIX= yes
GNU_CONFIGURE= yes