aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/hope/Makefile5
-rw-r--r--lang/hope/files/patch-src-memory.c11
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/hope/Makefile b/lang/hope/Makefile
index 970599bc1071..c38ef85999b6 100644
--- a/lang/hope/Makefile
+++ b/lang/hope/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hope
PORTVERSION= 0.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.soi.city.ac.uk/~ross/Hope/
DISTNAME= ${PORTNAME}
@@ -29,10 +30,6 @@ MAN1= hope.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not install"
-.endif
-
pre-fetch:
.if !defined(WITH_DOCS)
@${ECHO} ""
diff --git a/lang/hope/files/patch-src-memory.c b/lang/hope/files/patch-src-memory.c
new file mode 100644
index 000000000000..3d0f50cfac41
--- /dev/null
+++ b/lang/hope/files/patch-src-memory.c
@@ -0,0 +1,11 @@
+--- src/memory.c.orig Sun Dec 7 18:01:46 2003
++++ src/memory.c Sun Dec 7 18:01:50 2003
+@@ -22,6 +22,7 @@
+ {
+ if ((base_memory = (char *)malloc((size_t)MEMSIZE)) == NULL)
+ error(FATALERR, "can't allocate memory");
++ memset(base_memory, NULL, (size_t)MEMSIZE);
+ top_memory = base_memory + RoundDown(MEMSIZE);
+
+ lim_temp = top_string = base_memory;
+