aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.autotools.mk77
-rw-r--r--devel/autoconf213/Makefile4
-rw-r--r--devel/autoconf253/Makefile4
-rw-r--r--devel/autoconf259/Makefile2
-rw-r--r--devel/autoconf26/Makefile2
-rw-r--r--devel/autoconf261/Makefile2
-rw-r--r--devel/autoconf262/Makefile2
-rw-r--r--devel/autoconf267/Makefile2
-rw-r--r--devel/autoconf268/Makefile2
-rw-r--r--devel/automake110/Makefile5
-rw-r--r--devel/automake14/Makefile5
-rw-r--r--devel/automake15/Makefile5
-rw-r--r--devel/automake19/Makefile5
-rw-r--r--devel/libtool13/Makefile4
-rw-r--r--devel/libtool15/Makefile2
15 files changed, 35 insertions, 88 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 3a0b45909193..caed6ad08831 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -11,6 +11,21 @@
Autotools_Include_MAINTAINER= ade@FreeBSD.org
#---------------------------------------------------------------------------
+# IMPORTANT! READ ME! YES, THAT MEANS YOU!
+#
+# The "versioned" autotools referenced here are for BUILDING other ports
+# only. THIS CANNOT BE STRESSED HIGHLY ENOUGH. Things WILL BREAK if you
+# try to use them for anything other than ports/ work. This particularly
+# includes use as a run-time dependency.
+#
+# If you need unmodified versions of autotools, such as for use in an
+# IDE, then you MUST use the devel/gnu-* equivalents, and NOT these.
+# See devel/anjuta and devel/kdevelop for examples.
+#
+# You have been WARNED!
+#---------------------------------------------------------------------------
+
+#---------------------------------------------------------------------------
# Entry points into the autotools system
#---------------------------------------------------------------------------
#
@@ -21,10 +36,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# WANT_AUTOMAKE_VER=<value>
# - Port needs access to the automake build environment
#
-# WANT_AUTOMAKE_RUN=yes
-# - Port also needs access to automake as a run-time dependency
-# This is a NULL-OP if neither {USE,WANT}_AUTOMAKE_VER are defined
-#
# AUTOMAKE_ARGS=...
# - Extra arguments passed to automake during configure step
#
@@ -41,10 +52,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# WANT_AUTOCONF_VER=<value>
# - Port needs access to the autoconf build environment
#
-# WANT_AUTOCONF_RUN=yes
-# - Port also needs access to autoconf as a run-time dependency
-# This is a NULL-OP if neither {USE,WANT}_AUTOCONF_VER are defined
-#
# AUTOCONF_ARGS=...
# - Extra arguments passed to autoconf during configure step
#
@@ -69,10 +76,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# WANT_LIBTOOL_VER=<value>
# - Port needs access to the libtool build environment
#
-# WANT_LIBTOOL_RUN=yes
-# - Port also needs access to autoconf as a run-time dependency
-# This is a NULL-OP if neither {USE,WANT}_LIBTOOL_VER are defined
-#
# LIBTOOLFLAGS=<value>
# - Arguments passed to libtool during configure step
# Currently defaults to "--disable-ltlibs", but this will be going
@@ -83,51 +86,10 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
# Defaults to "aclocal.m4" if autoconf is in use, otherwise "configure"
#
#---------------------------------------------------------------------------
-# Major changes:
-#
-# - USE_AUTOMAKE, USE_AUTOCONF, USE_AUTOHEADER, and USE_LIBTOOL have
-# been deprecated in favor of USE_<x>_VER=...
-# As of 4/21/2004, changes should be made as follows:
-# USE_AUTOMAKE -> USE_AUTOMAKE_VER=14
-# USE_AUTOCONF -> USE_AUTOCONF_VER=213
-# USE_AUTOHEADER -> USE_AUTOHEADER_VER=213
-# USE_LIBTOOL -> USE_LIBTOOL_VER=13
-#
-# - additional variables WANT_{AUTOMAKE,AUTOCONF,AUTOHEADER,LIBTOOL}_RUN
-# have been added to include a run-time dependency on the appropriate
-# autotools port, as part of work in progress to remove ALL explicit
-# dependencies on autotools in port Makefiles, in favor of using the
-# autotools knobs
-#
-# - USE_LIBLTDL has been added as a convenience function to provide
-# a lib dependency on devel/libltdl15, so that if the major version
-# number changes in future, only one item has to be updated
-#
-# - {WANT,USE}_AUTOMAKE_VER no longer automatically brings in
-# autoconf as before, to allow for greater flexibility in version
-# matching, and to simplify bsd.autotools.mk
-# It is now the port Makefile responsibility to specifically bring
-# in the "appropriate" version of autoconf if automake is specified.
-# The mappings are as follows (automake,autoconf pairs):
-# (14,213) (15,253) (18,259)
-#
-# - Only set GNU_CONFIGURE automatically if USE_<x>_VER is specified,
-# since WANT_<x>_VER implies that we want the environment, but not
-# the configuration steps.
-#
-# Things to do:
-# - Work on killing off as many "old" autotools ports as possible
-#
-# - Bring back the installation of libtool .la files by default, removing
-# those FreeBSD-specific knobs added to prevent this
-#
-# - Migrate the myriad of autotools-related knobs into a single
-# USE_AUTOTOOLS=... (to be defined) variable, akin to USE_GNOME=...
#---------------------------------------------------------------------------
# DEPRECATED ENTRY POINTS
#---------------------------------------------------------------------------
-
.for i in AUTOMAKE AUTOCONF AUTOHEADER LIBTOOL
. if defined(USE_${i})
BROKEN= "USE_${i} deprecated: replace with USE_${i}_VER=..."
@@ -167,9 +129,6 @@ AUTOMAKE_VERSION= ${WANT_AUTOMAKE_VER}
AUTOMAKE_DEPENDS= ${AUTOMAKE}:${PORTSDIR}/devel/automake${AUTOMAKE_SUFFIX}
BUILD_DEPENDS+= ${AUTOMAKE_DEPENDS}
-. if defined(WANT_AUTOMAKE_RUN)
-RUN_DEPENDS+= ${AUTOMAKE_DEPENDS}
-. endif
# XXX: here be dragons, for some reason
#
@@ -230,9 +189,6 @@ AUTOCONF_VERSION= ${WANT_AUTOCONF_VER}
AUTOCONF_DEPENDS= ${AUTOCONF}:${PORTSDIR}/devel/autoconf${AUTOCONF_SUFFIX}
BUILD_DEPENDS+= ${AUTOCONF_DEPENDS}
-. if defined(WANT_AUTOCONF_RUN) || defined(WANT_AUTOHEADER_RUN)
-RUN_DEPENDS+= ${AUTOCONF_DEPENDS}
-. endif
.endif
@@ -283,9 +239,6 @@ LIBTOOL_VARS= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} LIBTOOL_M4=${LIBTOOL_
LIBTOOL_DEPENDS= ${LIBTOOL}:${PORTSDIR}/devel/libtool${LIBTOOL_SUFFIX}
BUILD_DEPENDS+= ${LIBTOOL_DEPENDS}
-. if defined(WANT_LIBTOOL_RUN)
-RUN_DEPENDS+= ${LIBTOOL_DEPENDS}
-. endif
LIBTOOLFLAGS?= --disable-ltlibs # XXX: probably not useful
. if defined(USE_AUTOCONF_VER)
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index e8a019605461..909755392f8f 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -14,9 +14,7 @@ MASTER_SITE_SUBDIR= ade/gnu
DISTNAME= autoconf-000227
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (legacy 2.13 version)
-
-DEPRECATED= Please use devel/autoconf259 instead
+COMMENT= Automatically configure source code on many Un*x platforms (2.13)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
diff --git a/devel/autoconf253/Makefile b/devel/autoconf253/Makefile
index ecc6801ef07a..8702efb35860 100644
--- a/devel/autoconf253/Makefile
+++ b/devel/autoconf253/Makefile
@@ -13,9 +13,7 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.53)
-
-DEPRECATED= Please use devel/autoconf259 instead
+COMMENT= Automatically configure source code on many Un*x platforms (2.53)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf26/Makefile b/devel/autoconf26/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf26/Makefile
+++ b/devel/autoconf26/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf261/Makefile b/devel/autoconf261/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf261/Makefile
+++ b/devel/autoconf261/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf267/Makefile b/devel/autoconf267/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf267/Makefile
+++ b/devel/autoconf267/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/autoconf268/Makefile b/devel/autoconf268/Makefile
index aa6be53c07c7..07d69bdb2976 100644
--- a/devel/autoconf268/Makefile
+++ b/devel/autoconf268/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= autoconf
DISTNAME= autoconf-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms (version 2.59)
+COMMENT= Automatically configure source code on many Un*x platforms (2.59)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
diff --git a/devel/automake110/Makefile b/devel/automake110/Makefile
index a9e072f2ace2..85ff655702db 100644
--- a/devel/automake110/Makefile
+++ b/devel/automake110/Makefile
@@ -13,10 +13,11 @@ MASTER_SITE_SUBDIR= automake
DISTNAME= automake-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (version 1.9)
+COMMENT= GNU Standards-compliant Makefile generator (1.9)
+
+RUN_DEPENDS= ${AUTOCONF_DEPENDS}
WANT_AUTOCONF_VER=259
-WANT_AUTOCONF_RUN=yes
BUILD_VERSION= 19
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
diff --git a/devel/automake14/Makefile b/devel/automake14/Makefile
index f50fc4457f41..a179cd5280b8 100644
--- a/devel/automake14/Makefile
+++ b/devel/automake14/Makefile
@@ -14,12 +14,11 @@ MASTER_SITE_SUBDIR= automake
DISTNAME= automake-1.4-p6
MAINTAINER= ade@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (legacy version 1.4)
+COMMENT= GNU Standards-compliant Makefile generator (1.4)
-DEPRECATED= Please use devel/automake19 instead
+RUN_DEPENDS= ${AUTOCONF_DEPENDS}
WANT_AUTOCONF_VER=213
-WANT_AUTOCONF_RUN=yes
BUILD_VERSION= 14
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
diff --git a/devel/automake15/Makefile b/devel/automake15/Makefile
index 4a725f1d3c6e..48119a0a5bec 100644
--- a/devel/automake15/Makefile
+++ b/devel/automake15/Makefile
@@ -14,12 +14,11 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
MAINTAINER= ade@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (version 1.5)
+COMMENT= GNU Standards-compliant Makefile generator (1.5)
-DEPRECATED= Please use devel/automake19 instead
+RUN_DEPENDS= ${AUTOCONF_DEPENDS}
WANT_AUTOCONF_VER=253
-WANT_AUTOCONF_RUN=yes
BUILD_VERSION= 15
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
diff --git a/devel/automake19/Makefile b/devel/automake19/Makefile
index a9e072f2ace2..85ff655702db 100644
--- a/devel/automake19/Makefile
+++ b/devel/automake19/Makefile
@@ -13,10 +13,11 @@ MASTER_SITE_SUBDIR= automake
DISTNAME= automake-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (version 1.9)
+COMMENT= GNU Standards-compliant Makefile generator (1.9)
+
+RUN_DEPENDS= ${AUTOCONF_DEPENDS}
WANT_AUTOCONF_VER=259
-WANT_AUTOCONF_RUN=yes
BUILD_VERSION= 19
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
diff --git a/devel/libtool13/Makefile b/devel/libtool13/Makefile
index 982bd9fe8cde..50136d7fefb9 100644
--- a/devel/libtool13/Makefile
+++ b/devel/libtool13/Makefile
@@ -14,9 +14,7 @@ MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT= Generic shared library support script (version 1.3)
-
-DEPRECATED= Please use devel/libtool15 instead
+COMMENT= Generic shared library support script (1.3)
BUILD_VERSION= 13
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index cebc05e9cdde..6f8a39d2e363 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT?= Generic shared library support script (version 1.5)
+COMMENT?= Generic shared library support script (1.5)
BUILD_VERSION= 15
LATEST_LINK?= libtool${BUILD_VERSION}