aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/py-wxPython/Makefile2
-rw-r--r--x11-toolkits/py-wxPython24/Makefile2
-rw-r--r--x11-toolkits/py-wxPython26/Makefile2
-rw-r--r--x11-toolkits/py-wxPython28/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/x11-toolkits/py-wxPython/Makefile b/x11-toolkits/py-wxPython/Makefile
index d147683f508e..047bbae2525f 100644
--- a/x11-toolkits/py-wxPython/Makefile
+++ b/x11-toolkits/py-wxPython/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
+BROKEN= "requires unstable development version of wxGTK, which isn't here yet"
+
WX_CONFIG= ${X11BASE}/bin/wx-config
USE_GMAKE= yes
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index d147683f508e..047bbae2525f 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
+BROKEN= "requires unstable development version of wxGTK, which isn't here yet"
+
WX_CONFIG= ${X11BASE}/bin/wx-config
USE_GMAKE= yes
diff --git a/x11-toolkits/py-wxPython26/Makefile b/x11-toolkits/py-wxPython26/Makefile
index d147683f508e..047bbae2525f 100644
--- a/x11-toolkits/py-wxPython26/Makefile
+++ b/x11-toolkits/py-wxPython26/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
+BROKEN= "requires unstable development version of wxGTK, which isn't here yet"
+
WX_CONFIG= ${X11BASE}/bin/wx-config
USE_GMAKE= yes
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index d147683f508e..047bbae2525f 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= ${PYDISTUTILS}
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
+BROKEN= "requires unstable development version of wxGTK, which isn't here yet"
+
WX_CONFIG= ${X11BASE}/bin/wx-config
USE_GMAKE= yes
2/+10 * - Combine clean-depends-list.sh into depends-list.shbdrewery2015-10-203-77/+45 * The command environment from r399703 is only needed if recursing.bdrewery2015-10-201-3/+6 * Fix test-depends after r399703.bdrewery2015-10-201-0/+1 * When listing dependencies, export the common command execution results.bdrewery2015-10-201-0/+2 * Add some work-in-progress scripts for splitting symbols out into PREFIX/lib/d...bdrewery2015-10-202-2/+50 * Switch strip test to using readelf(1) instead of file(1) to identify symbols.bdrewery2015-10-201-8/+6 * Make OpenJDK 1.8 the defaultswills2015-10-201-2/+2 * Improve shebangfix frameworkamdmi32015-10-191-14/+31 * Drop 8 support.mat2015-10-152-20/+0 * Readd PORTSDIR for now we will only start removing them after 2016Q1 is branchedbapt2015-10-1566-405/+405 * Temporary readd ${PORTSDIR} to perl5 deps as somewhow they are triggeringbapt2015-10-151-4/+4 * Drop the necessity to add ${PORTSDIR} to dependency linebapt2015-10-1566-415/+415 * Xorg-server update to 1.17.2 with related driver updates and bumps.kwm2015-10-131-2/+2 * Follow-up r399170 with a script, ports_env.sh, that can be used for the purpose.bdrewery2015-10-132-3/+16 * Add a function to export vars that bsd.port.mk generates from fork/exec.bdrewery2015-10-131-0/+51 * Don't check for minimal Pkg version for package building.bdrewery2015-10-131-1/+1 * Name the 'uname -r' variable the same as the bsd.port.subdir.mk version, _OSR...bdrewery2015-10-131-6/+6 * Apply export handling fixes from bsd.port.mk.bdrewery2015-10-131-14/+18 * Export more sysctl(8) vars.bdrewery2015-10-131-1/+7 * Remove debugging leftover from r399160.bdrewery2015-10-131-1/+0 * Export HAVE_COMPAT_IA32_KERN to sub-makes and ensure it is not exported if em...bdrewery2015-10-131-1/+3 * Move the exported variable assignments to where they are looked-up.bdrewery2015-10-131-1/+6 * Spell 'OSREL' properly from r399155.bdrewery2015-10-131-1/+1 * Don't check for minimal pkg version in sub-makes.bdrewery2015-10-131-2/+3 * Pass result of 'uname -r' to sub-makes to avoid unneeded lookup.bdrewery2015-10-131-2/+4 * Use a loop to export vars.bdrewery2015-10-131-5/+6 * Re-apply r398953 with protection for 'make *config*'.bdrewery2015-10-131-1/+1 * Replace escaping for exported vars with :Q feature.bdrewery2015-10-131-4/+4 * Remove SYSTEMVERSION exporting, not needed since r99913.bdrewery2015-10-131-2/+1 * Use -r flag for read command, this fixes handling of paths containingamdmi32015-10-121-1/+1 * Adding CPAL-1.0, https://opensource.org/licenses/CPAL-1.0pi2015-10-121-1/+4 * Add PLIST_DIRSTRY deprecation to sanity check (forgot to add it before)bapt2015-10-111-1/+2 * Avoid a useless call to dirnamebapt2015-10-111-1/+1 * Remove another unused variablebapt2015-10-111-1/+0 * Remove unused variablebapt2015-10-111-1/+0 * Check if the port directory is aboslute otherwise prepend ${PORTSDIR} in FETC...bapt2015-10-111-0/+4 * Revert r398953 per bdrewery demand it breaks make configbapt2015-10-111-1/+1 * Use USESDIR macrobapt2015-10-111-1/+1 * Remove iconv(), iconv_open() and iconv_close() symbols from libiconv.tijl2015-10-101-1/+1 * Don't include/parse bsd.options.desc.mk if not needed (showconfig or -V *_DESC).bdrewery2015-10-101-1/+1 * Make missing argument less obscure.bdrewery2015-10-101-4/+5 * Shift any arguments eaten up from getopts. This script takes no argumentsbdrewery2015-10-101-0/+1 * Unify depends-list.sh and all-depends-list.sh into one script, depends-list.sh.bdrewery2015-10-103-40/+18 * Add LOCALBASE-based ldconfig dir to plist for non-default PREFIXamdmi32015-10-081-17/+22 * Enable TEST option if DEVELOPER is setamdmi32015-10-081-0/+4 * Add a way to cleanly handle terminfo.db file used by devel/ncursesamdmi32015-10-083-1/+43 * - Fix compatibility with fmakeamdmi32015-10-081-1/+1 * Do not provide empty do-test target for perl5-using portsamdmi32015-10-081-1/+1 * www/firefox: update to 41.0swills2015-10-071-2/+2 * Add support for opt_TEST_TARGET consistent with opt_{ALL,INSTALL}_TARGETamdmi32015-10-051-2/+2 * - Add NO_PERL5_TEST: allow ports with USES=perl5 to run default do-test: defi...sunpoet2015-10-041-2/+2 * Fix opt_VARS premature expansion.mat2015-10-011-8/+8 * - Fix typoamdmi32015-09-301-1/+1 * Fix qt5-multimedia with GStreamer 1.6.0.kwm2015-09-291-1/+1 * Implemented complete support for test target.amdmi32015-09-295-17/+125 * Add a message explaining how to fix poudriere build failures if theadamw2015-09-281-0/+2 * Mk/bsd.gnome.mk : remove net/linc from the component list.rene2015-09-271-5/+1 * Update gstreamer1 ports to 1.6.0.kwm2015-09-261-3/+23 * Extend @sample to accept argumentsbapt2015-09-261-10/+15 * Explicitly run some gnome commands in post (de)installbapt2015-09-261-6/+6 * Explicitly run the ocaml command in post (de)installationbapt2015-09-261-3/+3 * Explicly force runnning load-octave-pkg during post (de)installationbapt2015-09-261-2/+2 * Restore _FORCE_POST_PATTERNS, some ports are were missed in the conversionantoine2015-09-261-1/+9 * ocamlfind is not run anymore from any @exec linesbapt2015-09-261-1/+0 * update-desktop-database is not used anymore @*execbapt2015-09-261-1/+0 * Convert update-mime-database into @post*bapt2015-09-261-1/+1 * Convert load-octave-pkg to proper @postexecbapt2015-09-261-1/+0 * Specify correctly @post* for gtk-query-immodulesbapt2015-09-261-3/+0 * Convert a bunch of @exec into proper @postexecbapt2015-09-261-1/+0 * mkfontscale and mkfontdir are not used anymore in @exec linesbapt2015-09-261-1/+1 * kldxref is not used anymore in any @execbapt2015-09-261-1/+1 * Bump the minimal version of pkg to 1.6.0bapt2015-09-261-1/+1 * Use @post[un]exec for ldconfig to ensure ldconfig is run when needed instead ofbapt2015-09-261-11/+10 * Add preliminary support of tlmgr.hrs2015-09-261-1/+1 * Remove another wrong commentbapt2015-09-251-1/+0 * Remove now wrong commentbapt2015-09-251-1/+0 * Allow slave ports to have a Makefile.local.bdrewery2015-09-221-0/+3 * Add description about background why arguments other thanhrs2015-09-201-0/+29 * Make all GNUstep ports install into the System domain so that the Local domai...theraven2015-09-191-0/+4 * Fixup gssapi.mk, no need to support more releases than needed, and usemat2015-09-191-3/+3 * Add a fixup for broken krb5-config script included in 9.Xhrs2015-09-191-0/+15 * Add KRB5CONFIG.hrs2015-09-181-1/+6 * Add a new sanity check for knobs not needed anymorebapt2015-09-171-0/+8 * - Update jpeg-turbo to 1.4.1 and grab maintainership after several timeoutsantoine2015-09-171-1/+6 * Remove ansi version fo wxGTK 2.8 and only keep the unicode versionbapt2015-09-171-72/+4 * textproc/py-xml: remove portrm2015-09-161-1/+0 * Update the Qt4 ports to 4.8.7.rakuco2015-09-162-6/+7 * - Use -isystem instead of -I to add ${LOCALBASE}/include to the list of heade...amdmi32015-09-161-3/+3 * Rewrite detection of GTK+3 supportolivierd2015-09-141-7/+14 * Since PEP 0488 and python 3.5, pyo files are eliminated and bytecode filesantoine2015-09-141-2/+7 * Make it so that the default Perl is always called perl5.mat2015-09-142-8/+29 * Uses/python.mk: Fix PYTHON_REL for pre-release Python versionskoobs2015-09-141-1/+5 * Add "fc", "fcfontsdir", "fontsdir", and "none" arguments to USES=fonts.hrs2015-09-141-5/+21 * Back-out r396454, it's broken on freebsd 9.3 (breaks at least ftp/curl)antoine2015-09-101-14/+4 * - Add KRB5CONFIG.hrs2015-09-091-4/+14 * Fix build_fs_violation for rebar3 builds.olgeni2015-09-091-1/+1 * Remove duplicate PDFTeX from the comment.jkim2015-09-091-1/+1 * - Update to 2.2.3sunpoet2015-09-091-2/+2 * - Update to 2.1.7sunpoet2015-09-091-2/+2 * - Update to 2.0.0p647sunpoet2015-09-091-2/+2 * [NEW] lang/python35: Welcome Python 3.5.x! (Note: RC3)koobs2015-09-091-1/+1 * Add PORTEXAMPLES to the options helpers.mat2015-09-081-2/+3 * - Split xpdfopen package from texlive-base. This is because it is the onlyhrs2015-09-081-4/+8 * - Move *_DEPENDS togethersunpoet2015-09-081-1/+1 * - Move *_DEPENDS togethersunpoet2015-09-081-1/+1 * - Move *_DEPENDS togethersunpoet2015-09-081-1/+1 * Remove libgnomedb component. The actualy port was removed April 2014 by bapt.kwm2015-09-061-5/+1 * Add DESKTOP_ENTRIES to the options flags.mat2015-09-051-9/+10 * http://cloud.github.com/ redirects to https.mat2015-09-051-1/+1 * Uses/iconv.mk: Set iconv-related CMake variables.rakuco2015-09-031-0/+17 * Fix error message when not finding a packagebapt2015-09-031-1/+1 * To ease up with future upgrades, move PERL_VERSION into a separate file.mat2015-08-311-5/+5 * Move one of the fallback site upperaz2015-08-301-1/+1 * Help portscout to detect a new version of the module on CPAN if the AUTHOR_IDaz2015-08-301-4/+4 * Update the USE_GNOME librsvg2 entry, which should have happened inkwm2015-08-301-1/+1 * - Add BROKEN_RUBYxx to simplify Makefilesunpoet2015-08-291-0/+8 * Use more precise wording, i.e. "set" and "append" instead of "run."adamw2015-08-291-4/+4 * Mk/bsd.port.mk: Add PKG_CREATE_VERBOSE functionalitymarino2015-08-281-0/+7 * Add generic opt_VARS/opt_VARS_OFF.mat2015-08-281-0/+29 * gecko: add INTEGER_SAMPLES optionjbeich2015-08-261-1/+11 * Make package-depends-list accept dependency entries without ${PORTSDIR}bapt2015-08-251-0/+4 * Make build-depends-list and run-depends-list accept dependency lines withoutbapt2015-08-25