aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ruby-term-ansicolor/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/ruby-term-ansicolor/Makefile b/devel/ruby-term-ansicolor/Makefile
index b87028371fa2..4a5717d19644 100644
--- a/devel/ruby-term-ansicolor/Makefile
+++ b/devel/ruby-term-ansicolor/Makefile
@@ -18,12 +18,17 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= Term::ANSIColor for Ruby
USE_RUBY= yes
-USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
+NO_BUILD= yes
+
DOCS= README.en
EXAMPLES= examples/*
+do-install:
+ @cd ${INSTALL_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP}
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}