aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/glib-networking/Makefile43
-rw-r--r--net/glib-networking/distinfo2
-rw-r--r--net/glib-networking/pkg-descr10
-rw-r--r--net/glib-networking/pkg-plist72
4 files changed, 127 insertions, 0 deletions
diff --git a/net/glib-networking/Makefile b/net/glib-networking/Makefile
new file mode 100644
index 000000000000..bc38988baf1e
--- /dev/null
+++ b/net/glib-networking/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: glib-networking
+# Date Created: 06 Jan 2011
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net/glib-networking/Makefile,v 1.12 2011/08/11 09:10:32 kwm Exp $
+#
+
+PORTNAME= glib-networking
+PORTVERSION= 2.28.7
+PORTREVISION= 3
+CATEGORIES= net
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Network-related giomodules for glib
+
+BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls \
+ gcrypt.18:${PORTSDIR}/security/libgcrypt \
+ dbus-1.3:${PORTSDIR}/devel/dbus \
+ proxy.1:${PORTSDIR}/net/libproxy
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
+ gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig glib20 intltool
+USE_GETTEXT= yes
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e' s|-Wmissing-include-dirs||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/glib-networking/distinfo b/net/glib-networking/distinfo
new file mode 100644
index 000000000000..9e274437856a
--- /dev/null
+++ b/net/glib-networking/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome2/glib-networking-2.28.7.tar.bz2) = 98bedfbd530c4b1b53c91025fe82290bafd289d249e4eb549c3b90d23a76021c
+SIZE (gnome2/glib-networking-2.28.7.tar.bz2) = 319260
diff --git a/net/glib-networking/pkg-descr b/net/glib-networking/pkg-descr
new file mode 100644
index 000000000000..aa77e641a5ce
--- /dev/null
+++ b/net/glib-networking/pkg-descr
@@ -0,0 +1,10 @@
+Network-related giomodules for glib.
+
+Glib-networking contains the implementations of certain GLib networking
+features that cannot be implemented directly in GLib itself because of their
+dependencies.
+
+Currently it contains a GNUTLS-based implementation of GTlsBackend,
+a libproxy-based implementation of GProxyResolver, and a GNOME GProxyResolver
+that uses the proxy information from the GSettings schemas in
+gsettings-desktop-schemas.
diff --git a/net/glib-networking/pkg-plist b/net/glib-networking/pkg-plist
new file mode 100644
index 000000000000..568a160a6e8f
--- /dev/null
+++ b/net/glib-networking/pkg-plist
@@ -0,0 +1,72 @@
+lib/gio/modules/libgiognomeproxy.a
+lib/gio/modules/libgiognomeproxy.la
+lib/gio/modules/libgiognomeproxy.so
+lib/gio/modules/libgiognutls.a
+lib/gio/modules/libgiognutls.la
+lib/gio/modules/libgiognutls.so
+lib/gio/modules/libgiolibproxy.a
+lib/gio/modules/libgiolibproxy.la
+lib/gio/modules/libgiolibproxy.so
+libexec/glib-pacrunner
+share/dbus-1/services/org.gtk.GLib.PACRunner.service
+share/locale/as/LC_MESSAGES/glib-networking.mo
+share/locale/bg/LC_MESSAGES/glib-networking.mo
+share/locale/bn_IN/LC_MESSAGES/glib-networking.mo
+share/locale/ca/LC_MESSAGES/glib-networking.mo
+share/locale/cs/LC_MESSAGES/glib-networking.mo
+share/locale/da/LC_MESSAGES/glib-networking.mo
+share/locale/de/LC_MESSAGES/glib-networking.mo
+share/locale/el/LC_MESSAGES/glib-networking.mo
+share/locale/en_CA/LC_MESSAGES/glib-networking.mo
+share/locale/en_GB/LC_MESSAGES/glib-networking.mo
+share/locale/eo/LC_MESSAGES/glib-networking.mo
+share/locale/es/LC_MESSAGES/glib-networking.mo
+share/locale/et/LC_MESSAGES/glib-networking.mo
+share/locale/eu/LC_MESSAGES/glib-networking.mo
+share/locale/fr/LC_MESSAGES/glib-networking.mo
+share/locale/gl/LC_MESSAGES/glib-networking.mo
+share/locale/gu/LC_MESSAGES/glib-networking.mo
+share/locale/he/LC_MESSAGES/glib-networking.mo
+share/locale/hi/LC_MESSAGES/glib-networking.mo
+share/locale/hu/LC_MESSAGES/glib-networking.mo
+share/locale/id/LC_MESSAGES/glib-networking.mo
+share/locale/it/LC_MESSAGES/glib-networking.mo
+share/locale/ja/LC_MESSAGES/glib-networking.mo
+share/locale/kn/LC_MESSAGES/glib-networking.mo
+share/locale/ko/LC_MESSAGES/glib-networking.mo
+share/locale/lv/LC_MESSAGES/glib-networking.mo
+share/locale/mr/LC_MESSAGES/glib-networking.mo
+share/locale/nb/LC_MESSAGES/glib-networking.mo
+share/locale/nl/LC_MESSAGES/glib-networking.mo
+share/locale/or/LC_MESSAGES/glib-networking.mo
+share/locale/pa/LC_MESSAGES/glib-networking.mo
+share/locale/pl/LC_MESSAGES/glib-networking.mo
+share/locale/pt/LC_MESSAGES/glib-networking.mo
+share/locale/pt_BR/LC_MESSAGES/glib-networking.mo
+share/locale/ro/LC_MESSAGES/glib-networking.mo
+share/locale/ru/LC_MESSAGES/glib-networking.mo
+share/locale/sl/LC_MESSAGES/glib-networking.mo
+share/locale/sr/LC_MESSAGES/glib-networking.mo
+share/locale/sr@latin/LC_MESSAGES/glib-networking.mo
+share/locale/sv/LC_MESSAGES/glib-networking.mo
+share/locale/tr/LC_MESSAGES/glib-networking.mo
+share/locale/ug/LC_MESSAGES/glib-networking.mo
+share/locale/uk/LC_MESSAGES/glib-networking.mo
+share/locale/vi/LC_MESSAGES/glib-networking.mo
+share/locale/zh_CN/LC_MESSAGES/glib-networking.mo
+share/locale/zh_HK/LC_MESSAGES/glib-networking.mo
+share/locale/zh_TW/LC_MESSAGES/glib-networking.mo
+@exec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
+@unexec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as