aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/brlcad/Makefile2
-rw-r--r--graphics/libdrm/Makefile3
-rw-r--r--net/x11vnc/Makefile2
-rw-r--r--print/photoprint/Makefile2
-rw-r--r--sysutils/nitrogen/Makefile2
5 files changed, 6 insertions, 5 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index 39940490e6e7..577d4dfb5bb1 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -24,7 +24,7 @@ USE_GL= gl glu
USE_XORG= ice inputproto sm x11 xau xcb xdamage xdmcp xext xfixes xft xi \
xproto xrender xscrnsaver xt xxf86vm
USE_GMAKE= yes
-USES= bison pathfix cmake
+USES= bison pathfix cmake pkgconfig
USE_TCL= 85
USE_TK= 85
USE_LDCONFIG= yes
diff --git a/graphics/libdrm/Makefile b/graphics/libdrm/Makefile
index 790933db7231..01aee31dcba3 100644
--- a/graphics/libdrm/Makefile
+++ b/graphics/libdrm/Makefile
@@ -13,6 +13,7 @@ COMMENT= Userspace interface to kernel Direct Rendering Module services
LIB_DEPENDS= pciaccess:${PORTSDIR}/devel/libpciaccess \
pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -20,7 +21,7 @@ USE_LDCONFIG= yes
.if defined(WITH_NEW_XORG)
-USE_GMAKE= yes
+USES+= gmake
OPTIONS_DEFINE= KMS MANPAGES
OPTIONS_DEFAULT=KMS
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index da1116fd144e..5d61384e3ae1 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -22,7 +22,7 @@ USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
-USES= iconv
+USES= iconv pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index c46713c00f9b..6c97b0844301 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client \
tiff:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext
+USES= desktop-file-utils gettext pkgconfig
USE_GNOME= pango
USE_XORG= x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
index f7813918244c..2ee386dc1e8b 100644
--- a/sysutils/nitrogen/Makefile
+++ b/sysutils/nitrogen/Makefile
@@ -32,7 +32,7 @@ RUN_DEPENDS= gnome-icon-theme>0:${PORTSDIR}/misc/gnome-icon-theme \
OPTIONS_DEFINE= XINERAMA
OPTIONS_DEFAULT=XINERAMA
-USES= gettext iconv
+USES= gettext iconv pkgconfig
USE_GNOME= gtk20
USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
xrandr xrender