aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-idna/Makefile19
-rw-r--r--dns/py-idna/distinfo2
-rw-r--r--dns/py-idna/pkg-descr10
4 files changed, 32 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 39ba997b78bd..41fd0c337952 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -163,6 +163,7 @@
SUBDIR += py-dns3
SUBDIR += py-dnspython
SUBDIR += py-easyzone
+ SUBDIR += py-idna
SUBDIR += py-idnkit2
SUBDIR += py-ldns
SUBDIR += py-namebench
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
new file mode 100644
index 000000000000..5cbaaf1746bd
--- /dev/null
+++ b/dns/py-idna/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= idna
+PORTVERSION= 2.0
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Internationalized Domain Names in Applications (IDNA)
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/dns/py-idna/distinfo b/dns/py-idna/distinfo
new file mode 100644
index 000000000000..67e147b4fe87
--- /dev/null
+++ b/dns/py-idna/distinfo
@@ -0,0 +1,2 @@
+SHA256 (idna-2.0.tar.gz) = 16199aad938b290f5be1057c0e1efc6546229391c23cea61ca940c115f7d3d3b
+SIZE (idna-2.0.tar.gz) = 135150
diff --git a/dns/py-idna/pkg-descr b/dns/py-idna/pkg-descr
new file mode 100644
index 000000000000..dd2b68ff56ca
--- /dev/null
+++ b/dns/py-idna/pkg-descr
@@ -0,0 +1,10 @@
+A library to support the Internationalised Domain Names in Applications
+(IDNA) protocol as specified in RFC 5891. This version of the protocol
+is often referred to as "IDNA2008" and can produce different res
+lts from the earlier standard from 2003.
+
+The library is also intended to act as a suitable drop-in replacement
+for the "encodings.idna" module that comes with the Python standard
+library but currently only supports the older 2003 specification.
+
+WWW: https://github.com/kjd/idna