aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/grip/Makefile4
-rw-r--r--audio/grip/files/patch-aa14
2 files changed, 12 insertions, 6 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 07c922d11dc7..10b9a7ecca98 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
USE_GTK= yes
-
ALL_TARGET= gripnopar gcd
-
MAN1= grip.1
MLINKS= grip.1 gcd.1
+MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
post-patch:
@${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/*.c
diff --git a/audio/grip/files/patch-aa b/audio/grip/files/patch-aa
index b02145a186e2..e2c2c0077cb2 100644
--- a/audio/grip/files/patch-aa
+++ b/audio/grip/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Oct 19 04:12:53 2000
-+++ Makefile Fri Oct 20 20:33:10 2000
-@@ -4,24 +4,24 @@
+--- Makefile.orig Thu Oct 19 04:42:53 2000
++++ Makefile Thu Jul 19 16:32:12 2001
+@@ -4,29 +4,29 @@
OS=$(shell uname -s)
# Compiler
@@ -21,7 +21,7 @@
# Compiler flags
-CFLAGS= -Wall `gtk-config --cflags` -DAUXDIR=\"$(AUXDIR)\" \
-+CFLAGS+= `$(GTK_CONFIG) --cflags gthread` -DAUXDIR=\"$(AUXDIR)\" \
++CFLAGS+= $(PTHREAD_CFLAGS) `$(GTK_CONFIG) --cflags gthread` -DAUXDIR=\"$(AUXDIR)\" \
-DINSTALLDIR=\"$(INSTALLDIR)\" -D_REENTRANT
# Link libraries
@@ -30,3 +30,9 @@
ifeq ($(OS), Linux)
LIBS+= -lpthread
endif
+ ifeq ($(OS), FreeBSD)
+-LIBS+= -pthread
++LIBS+= $(PTHREAD_LIBS)
+ endif
+ PARLIBS= cdparanoia/interface/libcdda_interface.a \
+ cdparanoia/paranoia/libcdda_paranoia.a
ove useless metadata from ports I created.des2012-09-051-5/+0 * Chase Emacs updatesashish2012-09-052-0/+2 * Update to latest version 3.3.39.zeising2012-09-0410-23/+5 * - Update to 3.316swills2012-08-282-3/+3 * - Update distinfo / plist because distfile was rerolled upstreamak2012-08-242-6/+5 * Update to 5.12crees2012-08-103-6/+11 * - Update to 2.1.0madpilot2012-08-102-6/+5 * - Mark as BROKEN: size mismatchbeat2012-08-061-0/+2 * - Remove some empty filesmiwi2012-08-052-0/+0 * - Update to 3.1miwi2012-08-052-17/+29 * - Update to 9.4cmiwi2012-08-054-33/+22 * - Update to 9.7.74miwi2012-08-055-62/+43 * - Update to 801miwi2012-08-054-22/+18 * Switch from libglut to freeglut and retire libglut. Libglut hasn't beenkwm2012-08-053-1/+5 * Mark BROKEN: does not builderwin2012-07-301-0/+2 * - Convert my ports to new options frameworkmakc2012-07-271-2/+4 * Use the new PKG_CONFIG macro.zeising2012-07-261-0/+1 * new devel/pkgconf added to replace devel/pkg-config. new version of pkg-configbapt2012-07-261-2/+1 * For ports maintained by ports@ where pkgconfig is one of the USE_GNOME depsdougb2012-07-231-1/+3 * Update to version 3.3.38, bugfix release.zeising2012-07-204-7/+8 * - Update to version 0.53.0sperber2012-07-204-15/+65 * - Add dependency on qt4-script [1]gahr2012-07-181-2/+1 * - Update to 0.24nivit2012-07-172-13/+20 * - Update to version 0.77.0pawel2012-07-127-123/+34 * add math/metis4 to math/Makefile; update math/metis to 5.0.2; add appropriatebf2012-07-092-4/+5 * Upgrade Code_Aster to 10.6.0-3.thierry2012-07-079-80/+156 * Upgrade to 2.6.0.thierry2012-07-077-83/+78 * Upgrade to 5.1.12b.thierry2012-07-075-44/+77 * Change maintainer address to my FreeBSD.org mail address.zeising2012-07-032-2/+2 * - Update to 1.3.0gahr2012-07-0210-75/+119 * - Update to 7.22.0 [1]scheidell2012-07-013-1388/+1431 * - Detect eigen2 by checking for .pc file, not min. port version.avilla2012-06-271-1/+1 * Update to 0.21.19.hrs2012-06-202-5/+6 * Bump PORTREVISION to reflect name change from devel/bazaar-ng --> devel/bzrcs2012-06-181-2/+2 * - Update to version 1.6.2sylvio2012-06-184-23/+2255 * - Update to 3.3.37ak2012-06-154-11/+9 * - Convert all remaining instances of BUILD_DEPENDS=${RUN_DEPENDS} orswills2012-06-11