aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/root-doc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/root-doc/Makefile b/devel/root-doc/Makefile
index 62d6bb4f1803..af25be765040 100644
--- a/devel/root-doc/Makefile
+++ b/devel/root-doc/Makefile
@@ -11,16 +11,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= HTML Documentation for Root framework
NO_BUILD= yes
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/htmldoc
PLIST= ${WRKDIR}/pkg-plist
pre-install:
- cd ${WRKSRC} && ${FIND} . \( -type f -or -type l \) -exec ${ECHO_CMD} \
- "%%DOCSDIR%%/{}" \; > ${PLIST}.tmp
- ${SED} -e "s/\/\.\//\//" ${PLIST}.tmp > ${PLIST}
+ @cd ${WRKSRC} && ${FIND} . \( -type f -or -type l \) -print | \
+ ${SED} -e 's|^\.|%%DOCSDIR%%|' > ${PLIST}
do-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>