aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/tank/Makefile8
-rw-r--r--games/tank/pkg-descr2
2 files changed, 8 insertions, 2 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index 18366118a24a..658bf669ed77 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -21,10 +21,16 @@ USE_GMAKE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= linux-mesa-elf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN=i "does not build on FreeBSD ${OSVERSION}"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/tank
${INSTALL_DATA} ${WRKSRC}/*.tga ${PREFIX}/share/tank
${INSTALL_DATA} ${WRKSRC}/*.au ${PREFIX}/share/tank
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/tank/pkg-descr b/games/tank/pkg-descr
index a7155276c6fd..67b4e57359a1 100644
--- a/games/tank/pkg-descr
+++ b/games/tank/pkg-descr
@@ -9,4 +9,4 @@ up display, etc.) make game play varied and more interesting.
This program was written as a final project for a computer graphics
course, and was originally developed under Linux.
-[ This port is maintained by Donald Burr <dburr@FreeBSD.ORG>. ]
+WWW: http://step.polymtl.ca/~coyote/graphics-tank/