aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/pvm++/Makefile5
-rw-r--r--net/pvm++/files/patch-examples-forkjoin-forkjoin.cc10
-rw-r--r--net/pvm++/files/patch-examples-talk-talk.hh7
-rw-r--r--net/pvm++/files/patch-mrt-base_file.h10
-rw-r--r--net/pvm++/files/patch-pvm++-class.cc11
-rw-r--r--net/pvm++/files/patch-pvm++-handlertabletype.cc11
-rw-r--r--net/pvm++/files/patch-pvm++-host.cc11
-rw-r--r--net/pvm++/files/patch-pvm++-internal.cc23
-rw-r--r--net/pvm++/files/patch-pvm++-internal.hh20
-rw-r--r--net/pvm++/files/patch-pvm++-internal.ii20
-rw-r--r--net/pvm++/files/patch-pvm++-private.hh11
-rw-r--r--net/pvm++/files/patch-pvm++-struct.cc11
-rw-r--r--net/pvm++/files/patch-pvm++-structset.cc11
-rw-r--r--net/pvm++/files/patch-pvm++-task.cc11
14 files changed, 159 insertions, 13 deletions
diff --git a/net/pvm++/Makefile b/net/pvm++/Makefile
index cd29d6688b2d..b26ecc722825 100644
--- a/net/pvm++/Makefile
+++ b/net/pvm++/Makefile
@@ -10,12 +10,11 @@ MASTER_SITES= SF/pvm-plus-plus/pvm-plus-plus/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++-Library for PVM
-BROKEN= Fails to patch
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libpvm3.a:${PORTSDIR}/net/pvm
+USES= gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pvm-incs=${LOCALBASE}/include \
--with-pvm-libs=${LOCALBASE}/lib
diff --git a/net/pvm++/files/patch-examples-forkjoin-forkjoin.cc b/net/pvm++/files/patch-examples-forkjoin-forkjoin.cc
new file mode 100644
index 000000000000..77e5af96216f
--- /dev/null
+++ b/net/pvm++/files/patch-examples-forkjoin-forkjoin.cc
@@ -0,0 +1,10 @@
+--- examples/forkjoin/forkjoin.cc.orig 2013-11-16 20:05:10.000000000 +0100
++++ examples/forkjoin/forkjoin.cc 2013-11-16 20:05:29.000000000 +0100
+@@ -5,6 +5,7 @@
+
+ /* defines and prototypes for the PVM++ and PVM libraries */
+
++#include <stdlib.h>
+ #include <pvm++/pvm++.hh>
+
+ /* Maximum number of children this program will spawn */
diff --git a/net/pvm++/files/patch-examples-talk-talk.hh b/net/pvm++/files/patch-examples-talk-talk.hh
new file mode 100644
index 000000000000..ae0cc71a3f01
--- /dev/null
+++ b/net/pvm++/files/patch-examples-talk-talk.hh
@@ -0,0 +1,7 @@
+--- examples/talk/talk.hh.orig 2013-11-16 20:05:10.000000000 +0100
++++ examples/talk/talk.hh 2013-11-16 20:05:46.000000000 +0100
+@@ -1,3 +1,4 @@
++#include <stdlib.h>
+ #include <pvm++/pvm++.hh>
+
+ const Pvm::StructId MessageId = 1;
diff --git a/net/pvm++/files/patch-mrt-base_file.h b/net/pvm++/files/patch-mrt-base_file.h
deleted file mode 100644
index 6f39e5ece4ce..000000000000
--- a/net/pvm++/files/patch-mrt-base_file.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- mrt/base_file.h.orig 2013-11-16 13:43:12.000000000 +0100
-+++ mrt/base_file.h 2013-11-16 13:44:09.000000000 +0100
-@@ -20,6 +20,7 @@
- */
-
- #include <string>
-+#include <sys/types.h>
- #include "export_mrt.h"
-
- namespace mrt {
diff --git a/net/pvm++/files/patch-pvm++-class.cc b/net/pvm++/files/patch-pvm++-class.cc
new file mode 100644
index 000000000000..aa2a5b0b0206
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-class.cc
@@ -0,0 +1,11 @@
+--- pvm++/class.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/class.cc 2013-11-16 20:02:45.000000000 +0100
+@@ -22,7 +22,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ void
+ Throw (int Error, const char *File, int Line)
diff --git a/net/pvm++/files/patch-pvm++-handlertabletype.cc b/net/pvm++/files/patch-pvm++-handlertabletype.cc
new file mode 100644
index 000000000000..f37fcd8efbb0
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-handlertabletype.cc
@@ -0,0 +1,11 @@
+--- pvm++/handlertabletype.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/handlertabletype.cc 2013-11-16 20:03:09.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ ReceiveAction
+ HandlerTableType::Install (Struct &Struct, ReceiveAction What)
diff --git a/net/pvm++/files/patch-pvm++-host.cc b/net/pvm++/files/patch-pvm++-host.cc
new file mode 100644
index 000000000000..e9cb3870a19a
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-host.cc
@@ -0,0 +1,11 @@
+--- pvm++/host.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/host.cc 2013-11-16 20:02:50.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ Host::operator unsigned int () const
+ {
diff --git a/net/pvm++/files/patch-pvm++-internal.cc b/net/pvm++/files/patch-pvm++-internal.cc
new file mode 100644
index 000000000000..9defbefc0528
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-internal.cc
@@ -0,0 +1,23 @@
+--- pvm++/internal.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/internal.cc 2013-11-16 20:02:56.000000000 +0100
+@@ -27,7 +27,7 @@
+ namespace Pvm
+ {
+
+- namespace Internal
++ namespace Internal_
+ {
+
+ void
+@@ -225,9 +225,9 @@
+ HandlerTableType *HandlerTable;
+ QueueType *ReceivedQueue;
+
+- } // namespace Internal
++ } // namespace Internal_
+
+- using namespace Internal;
++ using namespace Internal_;
+
+ void
+ AccessPrivate::UnPack (const QueueIterator &QueuePos, StructSet &What,
diff --git a/net/pvm++/files/patch-pvm++-internal.hh b/net/pvm++/files/patch-pvm++-internal.hh
new file mode 100644
index 000000000000..7b6042b28db7
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-internal.hh
@@ -0,0 +1,20 @@
+--- pvm++/internal.hh.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/internal.hh 2013-11-16 20:03:28.000000000 +0100
+@@ -37,7 +37,7 @@
+ long int EndSec, long int EnduSec);
+ };
+
+- namespace Internal
++ namespace Internal_
+ {
+
+ void GetTasks (int What, TaskSet & Result);
+@@ -69,7 +69,7 @@
+ extern HandlerTableType *HandlerTable;
+ extern QueueType *ReceivedQueue;
+
+- } // namespace Internal
++ } // namespace Internal_
+
+ } // namespace Pvm
+
diff --git a/net/pvm++/files/patch-pvm++-internal.ii b/net/pvm++/files/patch-pvm++-internal.ii
new file mode 100644
index 000000000000..3b4ac79fc51f
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-internal.ii
@@ -0,0 +1,20 @@
+--- pvm++/internal.ii.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/internal.ii 2013-11-16 20:03:32.000000000 +0100
+@@ -25,7 +25,7 @@
+ namespace Pvm
+ {
+
+- namespace Internal
++ namespace Internal_
+ {
+
+ inline
+@@ -57,7 +57,7 @@
+ return AccessPrivate::Select (StructSet, EndSec, EnduSec);
+ }
+
+- } // namespace Internal
++ } // namespace Internal_
+
+ } // namespace Pvm
+
diff --git a/net/pvm++/files/patch-pvm++-private.hh b/net/pvm++/files/patch-pvm++-private.hh
new file mode 100644
index 000000000000..2544c626e705
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-private.hh
@@ -0,0 +1,11 @@
+--- pvm++/private.hh.orig 2013-11-16 20:04:12.000000000 +0100
++++ pvm++/private.hh 2013-11-16 20:04:29.000000000 +0100
+@@ -20,6 +20,8 @@
+ #ifndef __PVM_PRIVATE_HH__
+ #define __PVM_PRIVATE_HH__
+
++#include <stdlib.h>
++
+ #include <pvm++/pvm++.hh>
+
+ #include <pvm++/privatetypes.hh>
diff --git a/net/pvm++/files/patch-pvm++-struct.cc b/net/pvm++/files/patch-pvm++-struct.cc
new file mode 100644
index 000000000000..f4ccdde57b99
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-struct.cc
@@ -0,0 +1,11 @@
+--- pvm++/struct.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/struct.cc 2013-11-16 20:03:01.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ Task Struct::IgnoreTask;
+ bool Struct::CurrentlyPacking;
diff --git a/net/pvm++/files/patch-pvm++-structset.cc b/net/pvm++/files/patch-pvm++-structset.cc
new file mode 100644
index 000000000000..50640e947de3
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-structset.cc
@@ -0,0 +1,11 @@
+--- pvm++/structset.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/structset.cc 2013-11-16 20:03:20.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ Task StructSet::IgnoreTask;
+
diff --git a/net/pvm++/files/patch-pvm++-task.cc b/net/pvm++/files/patch-pvm++-task.cc
new file mode 100644
index 000000000000..e8b26eb01956
--- /dev/null
+++ b/net/pvm++/files/patch-pvm++-task.cc
@@ -0,0 +1,11 @@
+--- pvm++/task.cc.orig 2013-11-16 19:59:44.000000000 +0100
++++ pvm++/task.cc 2013-11-16 20:03:04.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ namespace Pvm
+ {
+- using namespace Internal;
++ using namespace Internal_;
+
+ bool
+ Task::HasParent () const