aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/razorback-fsWalk/Makefile44
-rw-r--r--security/razorback-fsWalk/distinfo2
-rw-r--r--security/razorback-fsWalk/pkg-descr8
-rw-r--r--security/razorback-fsWalk/pkg-plist6
5 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4489f871bdc5..c8cb89728670 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -786,6 +786,7 @@
SUBDIR += rats
SUBDIR += razorback-api
SUBDIR += razorback-fileInject
+ SUBDIR += razorback-fsWalk
SUBDIR += rdigest
SUBDIR += retranslator
SUBDIR += revelation
diff --git a/security/razorback-fsWalk/Makefile b/security/razorback-fsWalk/Makefile
new file mode 100644
index 000000000000..4650144ab0e2
--- /dev/null
+++ b/security/razorback-fsWalk/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: razorback-fsWalk
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fsWalk
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Framework for an intelligence driven security - File System Walker
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
+
+OPTIONS= DEBUG "Enable Debug" off \
+ ASSERT "Enable Asserts" off
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if defined(WITH_ASSERT)
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/fsWalk.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/fsWalk.conf.sample ${PREFIX}/etc/razorback/fsWalk.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-fsWalk/distinfo b/security/razorback-fsWalk/distinfo
new file mode 100644
index 000000000000..b94cf81882a5
--- /dev/null
+++ b/security/razorback-fsWalk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/fsWalk-0.5.0.tar.gz) = 044240868fc04bad3c2e0eb2fa69ef9778ba51a479651d9592821b2ef742c1d0
+SIZE (razorback/fsWalk-0.5.0.tar.gz) = 315222
diff --git a/security/razorback-fsWalk/pkg-descr b/security/razorback-fsWalk/pkg-descr
new file mode 100644
index 000000000000..3742c9ac8e1a
--- /dev/null
+++ b/security/razorback-fsWalk/pkg-descr
@@ -0,0 +1,8 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+This nugget uses inotify to monitor any number of file system paths
+and send any changed or created files to the dispatcher for collection.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-fsWalk/pkg-plist b/security/razorback-fsWalk/pkg-plist
new file mode 100644
index 000000000000..b3a1caacd1ca
--- /dev/null
+++ b/security/razorback-fsWalk/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/fsWalk
+@unexec if cmp -s %D/etc/razorback/fsWalk.conf %D/etc/razorback/fsWalk.conf.sample; then rm -f %D/etc/razorback/fsWalk.conf; fi
+etc/razorback/fsWalk.conf.sample
+@exec if [ ! -f %D/etc/razorback/fsWalk.conf ]; then cp -p %D/%F %B/fsWalk.conf; fi
+@dirrmtry etc/razorback