aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Log-Dispatch/Makefile2
-rw-r--r--mail/p3scan/Makefile2
-rw-r--r--www/lifetype/Makefile4
-rw-r--r--www/plog/Makefile4
4 files changed, 6 insertions, 6 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index 31b1c5bfa08b..ab8d57f5c277 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -69,7 +69,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite
BUILD_DEPENDS+= ${SITE_PERL}/Mail/Send.pm:${PORTSDIR}/mail/p5-Mail-Tools
.endif
-.if defined(WITH_EMAIL_MAILSENDMAIL)
+.if !defined(WITHOUT_EMAIL_MAILSENDMAIL)
BUILD_DEPENDS+= ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail
.endif
diff --git a/mail/p3scan/Makefile b/mail/p3scan/Makefile
index e4ae504af518..34a2c180f9e4 100644
--- a/mail/p3scan/Makefile
+++ b/mail/p3scan/Makefile
@@ -31,7 +31,7 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_UVSCAN) && ${WITH_UVSCAN:L} == "true"
+.if !defined(WITHOUT_UVSCAN)
RUN_DEPENDS+= uvscan:${PORTSDIR}/security/vscan
.endif
diff --git a/www/lifetype/Makefile b/www/lifetype/Makefile
index 65cf7741b270..90ba930d0d65 100644
--- a/www/lifetype/Makefile
+++ b/www/lifetype/Makefile
@@ -28,7 +28,7 @@ OPTIONS= GD "With GD Support" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
+.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.endif
@@ -36,7 +36,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
.endif
-.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+.if defined(WITHOUT_GD) && !defined(WITH_IMAGICK)
pre-patch:
@${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
.endif
diff --git a/www/plog/Makefile b/www/plog/Makefile
index 65cf7741b270..90ba930d0d65 100644
--- a/www/plog/Makefile
+++ b/www/plog/Makefile
@@ -28,7 +28,7 @@ OPTIONS= GD "With GD Support" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
+.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.endif
@@ -36,7 +36,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
.endif
-.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+.if defined(WITHOUT_GD) && !defined(WITH_IMAGICK)
pre-patch:
@${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
.endif