aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/unuran/Makefile10
-rw-r--r--math/unuran/files/patch-doc_Makefile.in8
2 files changed, 10 insertions, 8 deletions
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index 8a83056cf8c6..438ff3bcc3e6 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -11,9 +11,11 @@ MASTER_SITES= http://statmath.wu-wien.ac.at/unuran/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Universal Non-Uniform RANdom number generators
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= librngstreams.so:math/rngstreams
-LICENSE= GPLv2
USES= gmake libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstream \
@@ -29,13 +31,13 @@ PORTDOCS= unuran.pdf unuran.txt
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${MAKE_CMD}/' \
+ @${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${MAKE_CMD}/' \
${WRKSRC}/Makefile.in
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for DD in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${STAGEDIR}${DOCSDIR}
.endfor
.ifdef(MAINTAINER_MODE)
diff --git a/math/unuran/files/patch-doc_Makefile.in b/math/unuran/files/patch-doc_Makefile.in
index 96a56fc0c3fc..8adf957bd4cf 100644
--- a/math/unuran/files/patch-doc_Makefile.in
+++ b/math/unuran/files/patch-doc_Makefile.in
@@ -1,7 +1,7 @@
---- doc/Makefile.in.orig 2008-11-14 16:43:07.846169643 -0500
-+++ doc/Makefile.in 2008-11-14 16:43:34.409120521 -0500
-@@ -47,7 +47,7 @@
- CONFIG_CLEAN_FILES =
+--- doc/Makefile.in.orig 2011-04-19 10:50:45 UTC
++++ doc/Makefile.in
+@@ -50,7 +50,7 @@ CONFIG_CLEAN_FILES =
+ CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
-INFO_DEPS = $(srcdir)/unuran.info $(srcdir)/unuran_win32.info