aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/openvpn-devel/Makefile1
-rw-r--r--security/openvpn-devel/files/openvpn.sh.in6
-rw-r--r--security/openvpn/Makefile1
-rw-r--r--security/openvpn/files/openvpn.sh.in6
-rw-r--r--security/openvpn20/Makefile1
-rw-r--r--security/openvpn20/files/openvpn.sh.in6
6 files changed, 18 insertions, 3 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 36969729e880..3eaa4c233226 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openvpn
DISTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://openvpn.net/release/
diff --git a/security/openvpn-devel/files/openvpn.sh.in b/security/openvpn-devel/files/openvpn.sh.in
index 07f6447e9ea0..1330f7a550f4 100644
--- a/security/openvpn-devel/files/openvpn.sh.in
+++ b/security/openvpn-devel/files/openvpn.sh.in
@@ -59,7 +59,11 @@ prefix="%%PREFIX%%"
openvpn_precmd()
{
for i in $openvpn_if ; do
- if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 ; then
+ # FreeBSD <= 5.4 does not know kldstat's -m option
+ # FreeBSD >= 6.0 does not add debug.* sysctl information
+ # in the default build - we check both to keep things simple
+ if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 \
+ && ! kldstat -m if_${i} >/dev/null 2>&1 ; then
if ! kldload if_${i} ; then
warn "Could not load $i module."
return 1
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 36969729e880..3eaa4c233226 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openvpn
DISTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://openvpn.net/release/
diff --git a/security/openvpn/files/openvpn.sh.in b/security/openvpn/files/openvpn.sh.in
index 07f6447e9ea0..1330f7a550f4 100644
--- a/security/openvpn/files/openvpn.sh.in
+++ b/security/openvpn/files/openvpn.sh.in
@@ -59,7 +59,11 @@ prefix="%%PREFIX%%"
openvpn_precmd()
{
for i in $openvpn_if ; do
- if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 ; then
+ # FreeBSD <= 5.4 does not know kldstat's -m option
+ # FreeBSD >= 6.0 does not add debug.* sysctl information
+ # in the default build - we check both to keep things simple
+ if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 \
+ && ! kldstat -m if_${i} >/dev/null 2>&1 ; then
if ! kldload if_${i} ; then
warn "Could not load $i module."
return 1
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index 36969729e880..3eaa4c233226 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openvpn
DISTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://openvpn.net/release/
diff --git a/security/openvpn20/files/openvpn.sh.in b/security/openvpn20/files/openvpn.sh.in
index 07f6447e9ea0..1330f7a550f4 100644
--- a/security/openvpn20/files/openvpn.sh.in
+++ b/security/openvpn20/files/openvpn.sh.in
@@ -59,7 +59,11 @@ prefix="%%PREFIX%%"
openvpn_precmd()
{
for i in $openvpn_if ; do
- if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 ; then
+ # FreeBSD <= 5.4 does not know kldstat's -m option
+ # FreeBSD >= 6.0 does not add debug.* sysctl information
+ # in the default build - we check both to keep things simple
+ if ! sysctl debug.if_${i}_debug >/dev/null 2>&1 \
+ && ! kldstat -m if_${i} >/dev/null 2>&1 ; then
if ! kldload if_${i} ; then
warn "Could not load $i module."
return 1