aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/obfsproxy/Makefile40
-rw-r--r--security/obfsproxy/distinfo2
-rw-r--r--security/obfsproxy/files/pkg-message.in11
-rw-r--r--security/obfsproxy/pkg-descr6
5 files changed, 60 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 67587fcfe70a..a572726c39de 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -321,6 +321,7 @@
SUBDIR += nmapsi4
SUBDIR += nss
SUBDIR += oath-toolkit
+ SUBDIR += obfsproxy
SUBDIR += ocaml-cryptgps
SUBDIR += ocaml-cryptokit
SUBDIR += ocaml-ssl
diff --git a/security/obfsproxy/Makefile b/security/obfsproxy/Makefile
new file mode 100644
index 000000000000..00f231d008e9
--- /dev/null
+++ b/security/obfsproxy/Makefile
@@ -0,0 +1,40 @@
+# ports collection makefile for: obfsproxy
+# Date created: 20120220
+# Whom: Carlo Strub
+#
+# $FreeBSD$
+#
+
+PORTNAME= obfsproxy
+DISTVERSION= 20120216
+CATEGORIES= security net
+MASTER_SITES= https://www.c-s.li/ports/
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Tool to obfuscate Tor traffic
+
+LICENSE= BSD
+
+BUILD_DEPENDS= tor:${PORTSDIR}/security/tor-devel
+RUN_DEPENDS= tor:${PORTSDIR}/security/tor-devel
+LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
+
+USE_AUTOTOOLS= aclocal autoconf autoheader automake
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT= yes
+
+ACLOCAL_ARGS= -I m4
+AUTOCONF_ARGS= --include=m4
+AUTOHEADER_ARGS= --include=m4
+AUTOMAKE_ARGS= --add-missing --copy --force-missing
+MAN1= obfsproxy.1
+SUB_FILES= pkg-message
+PLIST_FILES= bin/obfsproxy
+USE_GNOME= pkgconfig
+
+MAKE_JOBS_SAFE= yes
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/obfsproxy/distinfo b/security/obfsproxy/distinfo
new file mode 100644
index 000000000000..c4341a7c176a
--- /dev/null
+++ b/security/obfsproxy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (obfsproxy-20120216.tar.gz) = fff79794932933345fafaf25ccec2bbd4b9a9067f05c081c9abb64635c5debb4
+SIZE (obfsproxy-20120216.tar.gz) = 121713
diff --git a/security/obfsproxy/files/pkg-message.in b/security/obfsproxy/files/pkg-message.in
new file mode 100644
index 000000000000..15142b932205
--- /dev/null
+++ b/security/obfsproxy/files/pkg-message.in
@@ -0,0 +1,11 @@
+================================================================================
+As a client, add the following to %%PREFIX%%/etc/tor/torrc:
+
+ UseBridges 1
+ Bridge obfs2 x.x.x.x:yyyy
+ ClientTransportPlugin obfs2 exec %%PREFIX%%/bin/obfsproxy --managed
+
+As a bridge, add the following to %%PREFIX%%/etc/tor/torrc:
+
+ ServerTransportPlugin obfs2 exec %%PREFIX%%/bin/obfsproxy --managed
+================================================================================
diff --git a/security/obfsproxy/pkg-descr b/security/obfsproxy/pkg-descr
new file mode 100644
index 000000000000..b61fb4b2c7a3
--- /dev/null
+++ b/security/obfsproxy/pkg-descr
@@ -0,0 +1,6 @@
+obfsproxy is a tool that attempts to circumvent censorship, by transforming the
+Tor traffic between the client and the bridge. This way, censors, who usually
+monitor traffic between the client and the bridge, will see innocent-looking
+transformed traffic instead of the actual Tor traffic.
+
+WWW: https://www.torproject.org/projects/obfsproxy.html.en