aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/drupal6-advanced_help/Makefile5
-rw-r--r--www/drupal6-cck/Makefile5
-rw-r--r--www/drupal6-chaos/Makefile5
-rw-r--r--www/drupal6-ckeditor/Makefile2
-rw-r--r--www/drupal6-content_access/Makefile5
-rw-r--r--www/drupal6-geshifilter/Makefile5
-rw-r--r--www/drupal6-google_analytics/Makefile5
-rw-r--r--www/drupal6-image/Makefile5
-rw-r--r--www/drupal6-imce/Makefile5
-rw-r--r--www/drupal6-menu_block/Makefile5
-rw-r--r--www/drupal6-mimedetect/Makefile5
-rw-r--r--www/drupal6-nice_menus/Makefile5
-rw-r--r--www/drupal6-nodewords/Makefile5
-rw-r--r--www/drupal6-page_title/Makefile5
-rw-r--r--www/drupal6-panels/Makefile5
-rw-r--r--www/drupal6-path_redirect/Makefile5
-rw-r--r--www/drupal6-pathauto/Makefile5
-rw-r--r--www/drupal6-print/Makefile5
-rw-r--r--www/drupal6-seo_checklist/Makefile5
-rw-r--r--www/drupal6-services/Makefile5
-rw-r--r--www/drupal6-tagadelic/Makefile5
-rw-r--r--www/drupal6-token/Makefile5
-rw-r--r--www/drupal6-views/Makefile5
-rw-r--r--www/drupal6-webform/Makefile5
-rw-r--r--www/drupal6-wysiwyg/Makefile5
-rw-r--r--www/drupal6-zeropoint/Makefile6
-rw-r--r--www/drupal6/Makefile2
-rw-r--r--www/drupal7-wysiwyg/Makefile6
-rw-r--r--www/drupal7/Makefile2
29 files changed, 56 insertions, 82 deletions
diff --git a/www/drupal6-advanced_help/Makefile b/www/drupal6-advanced_help/Makefile
index 62a23b13db8d..a042dcda9ab3 100644
--- a/www/drupal6-advanced_help/Makefile
+++ b/www/drupal6-advanced_help/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= rea@FreeBSD.org
COMMENT= Allows to store module help pages outside the module system
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= help \
help_example/help help_example/translations help_example \
@@ -48,6 +49,4 @@ MODULE_FILES= help/advanced_help.help.ini help/ini-file.html \
translations/fr.po
DOC_FILES= LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-cck/Makefile b/www/drupal6-cck/Makefile
index 49fe103a2327..a36425c76ab5 100644
--- a/www/drupal6-cck/Makefile
+++ b/www/drupal6-cck/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= rea@FreeBSD.org
COMMENT= Drupal 6 Content Construction Kit module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations/help/de translations/help translations \
theme tests \
@@ -246,6 +247,4 @@ MODULE_FILES= help/add-existing-field.html \
DOC_FILES= CHANGELOG.txt DEVELOPER.txt README.txt UPGRADE.txt \
LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-chaos/Makefile b/www/drupal6-chaos/Makefile
index 4114729da2af..2a3a27ba0012 100644
--- a/www/drupal6-chaos/Makefile
+++ b/www/drupal6-chaos/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x Chaos tool suite module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= views_content/translations views_content/plugins/views/translations \
@@ -370,6 +371,4 @@ DOC_DIRS= ctools_plugin_example
DOC_FILES= ctools_plugin_example/README.txt LICENSE.txt \
CHANGELOG.txt API.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-ckeditor/Makefile b/www/drupal6-ckeditor/Makefile
index 7cc92065b3d9..c29f06fc6864 100644
--- a/www/drupal6-ckeditor/Makefile
+++ b/www/drupal6-ckeditor/Makefile
@@ -17,6 +17,7 @@ EXTRACT_ONLY= ckeditor-6.x-1.1.tar.gz
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x Ckeditor WYSIWYG HTML editor
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations plugins/mediaembed/images \
@@ -317,7 +318,6 @@ DOC_FILES= ckeditor/LICENSE.html ckeditor/INSTALL.html \
LICENSE.txt CHANGELOG.txt
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
post-extract:
@cd ${WRKSRC} && ${TAR} xf ${DISTDIR}/${DIST_SUBDIR}/ckeditor_3.3.tar.gz
diff --git a/www/drupal6-content_access/Makefile b/www/drupal6-content_access/Makefile
index 582a77ab5d42..3e46cb3377ce 100644
--- a/www/drupal6-content_access/Makefile
+++ b/www/drupal6-content_access/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x Content Access module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations tests
@@ -32,6 +33,4 @@ MODULE_FILES= tests/content_access.test \
DOC_FILES= README.txt UPGRADE.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-geshifilter/Makefile b/www/drupal6-geshifilter/Makefile
index 7670c5a175da..ffa77bd5f70e 100644
--- a/www/drupal6-geshifilter/Makefile
+++ b/www/drupal6-geshifilter/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/php/geshi/geshi.php:${PORTSDIR}/devel/php5-geshi
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= geshi-extra tests translations
MODULE_FILES= geshi-extra/drupal5.php geshi-extra/drupal6.php \
@@ -42,6 +43,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-google_analytics/Makefile b/www/drupal6-google_analytics/Makefile
index 43e5a4e849bd..a34194eca36a 100644
--- a/www/drupal6-google_analytics/Makefile
+++ b/www/drupal6-google_analytics/Makefile
@@ -13,6 +13,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Adds the Google Analytics web stats tracking system to your website
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= tests/googleanalytics_basic.test googleanalytics.admin.inc \
@@ -26,6 +27,4 @@ MODULE_DIRS= tests translations
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-image/Makefile b/www/drupal6-image/Makefile
index e15b43cef774..a5c7577a956f 100644
--- a/www/drupal6-image/Makefile
+++ b/www/drupal6-image/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x image upload module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= views/theme views translations tests \
@@ -151,6 +152,4 @@ MODULE_FILES= contrib/image_attach/tests/image_attach.test \
DOC_FILES= LICENSE.txt CHANGELOG.txt INSTALL.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-imce/Makefile b/www/drupal6-imce/Makefile
index 62cbdb61bad5..9384e1e146da 100644
--- a/www/drupal6-imce/Makefile
+++ b/www/drupal6-imce/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x image/file uploader module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations tpl js inc css
@@ -56,6 +57,4 @@ MODULE_FILES= translations/uk.po \
DOC_FILES= README.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-menu_block/Makefile b/www/drupal6-menu_block/Makefile
index ef51e45c8bcc..0d82066fe991 100644
--- a/www/drupal6-menu_block/Makefile
+++ b/www/drupal6-menu_block/Makefile
@@ -13,6 +13,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Drupal module to provide configurable menu tree blocks
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= translations/menu_block.pot menu-block-admin.css \
menu-block-wrapper.tpl.php menu-block.js \
@@ -23,6 +24,4 @@ MODULE_DIRS= translations
DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-mimedetect/Makefile b/www/drupal6-mimedetect/Makefile
index f6a62a80df88..f7cc8ae10ed9 100644
--- a/www/drupal6-mimedetect/Makefile
+++ b/www/drupal6-mimedetect/Makefile
@@ -13,12 +13,11 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= wenheping@gmail.com
COMMENT= An API for Consistent Server Side Mime Detection
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= magic magic.mgc magic.mime \
mimedetect.info mimedetect.install mimedetect.module
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-nice_menus/Makefile b/www/drupal6-nice_menus/Makefile
index ddd0fc6e26c5..746e568eff40 100644
--- a/www/drupal6-nice_menus/Makefile
+++ b/www/drupal6-nice_menus/Makefile
@@ -13,6 +13,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= CSS / Javascript pull-down menus for Drupal
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= po translations
@@ -25,6 +26,4 @@ MODULE_FILES= po/ja.po po/nice_menus.pot arrow-down.png arrow-left.png \
DOC_FILES= CHANGELOG.txt README.txt UPGRADE.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-nodewords/Makefile b/www/drupal6-nodewords/Makefile
index 027e5595907b..2263a9e3899f 100644
--- a/www/drupal6-nodewords/Makefile
+++ b/www/drupal6-nodewords/Makefile
@@ -12,6 +12,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= A drupal module which allows the end-user to set meta tags for nodes
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= nodewords_basic/translations nodewords_basic \
nodewords_extra/translations nodewords_extra includes \
@@ -43,6 +44,4 @@ MODULE_FILES= includes/forum.inc includes/image.inc includes/node.inc \
DOC_FILES= README.txt CHANGELOG.txt API.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-page_title/Makefile b/www/drupal6-page_title/Makefile
index 5c20bdc014e5..f15e042923d4 100644
--- a/www/drupal6-page_title/Makefile
+++ b/www/drupal6-page_title/Makefile
@@ -15,6 +15,7 @@ COMMENT= Drupal module to provide fine-grained control of page titles
RUN_DEPENDS= drupal6-token>=0:${PORTSDIR}/www/drupal6-token
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= translations/page_title.pot translations/ru.po \
page_title-admin-settings-form.tpl.php page_title.admin.inc \
@@ -23,6 +24,4 @@ MODULE_DIRS= translations
DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-panels/Makefile b/www/drupal6-panels/Makefile
index e7c83f52949b..abf3f828d3d9 100644
--- a/www/drupal6-panels/Makefile
+++ b/www/drupal6-panels/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Drupal 6.x panels module
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations templates plugins/task_handlers \
@@ -192,6 +193,4 @@ DOC_FILES= README.txt LICENSE.txt \
KNOWN_ISSUES.txt INSTALL.txt \
D6UPDATE.txt CHANGELOG.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-path_redirect/Makefile b/www/drupal6-path_redirect/Makefile
index aadfd19dad24..6f710825a773 100644
--- a/www/drupal6-path_redirect/Makefile
+++ b/www/drupal6-path_redirect/Makefile
@@ -12,6 +12,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Drupal module to allow redirects
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= generate/path_redirect_generate.drush.inc \
@@ -25,6 +26,4 @@ MODULE_DIRS= generate
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-pathauto/Makefile b/www/drupal6-pathauto/Makefile
index 2186cb238304..687b9a52b8e7 100644
--- a/www/drupal6-pathauto/Makefile
+++ b/www/drupal6-pathauto/Makefile
@@ -14,6 +14,7 @@ COMMENT= Automatically generates URLs for Drupal content
RUN_DEPENDS= drupal6-token>=0:${PORTSDIR}/www/drupal6-token
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= pathauto.admin.inc pathauto.inc pathauto.info \
pathauto.install pathauto.js pathauto.module \
@@ -28,6 +29,4 @@ MODULE_DIRS= translations
DOC_FILES= INSTALL.txt API.txt README.txt i18n-ascii.example.txt \
LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-print/Makefile b/www/drupal6-print/Makefile
index f0d681d065d7..6dbca4ba3795 100644
--- a/www/drupal6-print/Makefile
+++ b/www/drupal6-print/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= rea@FreeBSD.org
COMMENT= Drupal 6 module that add printer-friendly pages
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= icons translations
MODULE_FILES= icons/mail_icon.gif icons/pdf_icon.gif icons/print_icon.gif \
@@ -34,6 +35,4 @@ MODULE_FILES= icons/mail_icon.gif icons/pdf_icon.gif icons/print_icon.gif \
DOC_FILES= CHANGELOG.txt CREDITS.txt INSTALL.txt \
LICENSE.txt MAINTAINERS.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-seo_checklist/Makefile b/www/drupal6-seo_checklist/Makefile
index 8d306bcdac42..f929df8e72d5 100644
--- a/www/drupal6-seo_checklist/Makefile
+++ b/www/drupal6-seo_checklist/Makefile
@@ -13,10 +13,9 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Drupal module to provide checklist of actions for SEO
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= seochecklist.info seochecklist.install seochecklist.module
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-services/Makefile b/www/drupal6-services/Makefile
index 00a1e7a00f5f..ab9923fe1507 100644
--- a/www/drupal6-services/Makefile
+++ b/www/drupal6-services/Makefile
@@ -12,6 +12,7 @@ CATEGORIES= www
MAINTAINER= whitekid@gmail.com
COMMENT= Provide an API for creating drupal web services.
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= auth/services_keyauth auth servers/xmlrpc_server servers \
services/comment_service services/file_service \
@@ -64,6 +65,4 @@ MODULE_FILES= auth/services_keyauth/services_keyauth.admin.inc \
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-tagadelic/Makefile b/www/drupal6-tagadelic/Makefile
index f75bc00f8348..00f09b635b27 100644
--- a/www/drupal6-tagadelic/Makefile
+++ b/www/drupal6-tagadelic/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://ftp.drupal.org/files/projects/
MAINTAINER= rea@FreeBSD.org
COMMENT= Tagadelic module for Drupal 6
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= translations
MODULE_FILES= tagadelic.css tagadelic.info tagadelic.install \
@@ -26,6 +27,4 @@ MODULE_FILES= tagadelic.css tagadelic.info tagadelic.install \
translations/ru.po translations/tagadelic.pot
DOC_FILES= LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-token/Makefile b/www/drupal6-token/Makefile
index f05ee27df64a..56803a45f16a 100644
--- a/www/drupal6-token/Makefile
+++ b/www/drupal6-token/Makefile
@@ -13,6 +13,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Token module for Drupal
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= translations/token.pot translations/da.po translations/de.po \
translations/es.po translations/hu.po translations/ja.po \
@@ -26,6 +27,4 @@ MODULE_DIRS= translations
DOC_FILES= API.txt LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-views/Makefile b/www/drupal6-views/Makefile
index 7f2a6a37b027..7af9a65e1b80 100644
--- a/www/drupal6-views/Makefile
+++ b/www/drupal6-views/Makefile
@@ -12,6 +12,7 @@ CATEGORIES= www
MAINTAINER= rea@FreeBSD.org
COMMENT= Controls how content lists are generated
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_DIRS= css \
docs \
@@ -406,6 +407,4 @@ module-dirs: patch
module-files: patch
@cd ${WRKSRC}; ${FIND} -s . -type f -d | ${SED} -e's|^\./| |;s|$$| \\|'
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-webform/Makefile b/www/drupal6-webform/Makefile
index 72c3d548cc7f..c70ad38db79b 100644
--- a/www/drupal6-webform/Makefile
+++ b/www/drupal6-webform/Makefile
@@ -13,6 +13,7 @@ CATEGORIES= www
MAINTAINER= nick@foobar.org
COMMENT= Drupal module to allow easy creation of forms
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= components/date.inc components/email.inc \
@@ -38,6 +39,4 @@ MODULE_DIRS= components tests translations
DOC_FILES= CHANGELOG.txt INSTALL.txt README.txt THEMING.txt LICENSE.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-wysiwyg/Makefile b/www/drupal6-wysiwyg/Makefile
index 3eb89238d5e8..fb96ee38de03 100644
--- a/www/drupal6-wysiwyg/Makefile
+++ b/www/drupal6-wysiwyg/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS+= ${LOCALBASE}/${TINYMCEDIR}:${PORTSDIR}/www/tinymce3
PLIST_FILES+= ${DRUPAL_MODDIR}/tinymce
+USE_DRUPAL= yes
DRUPAL6_MODULE= yes
MODULE_FILES= editors/css/openwysiwyg.css \
editors/css/tinymce-2.css \
@@ -73,6 +74,4 @@ DOC_FILES= CHANGELOG.txt README.txt LICENSE.txt
post-install:
${LN} -s ${PREFIX}/${TINYMCEDIR} ${PREFIX}/${DRUPAL_MODDIR}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal6-zeropoint/Makefile b/www/drupal6-zeropoint/Makefile
index eb1dfba784ac..e665af201cc7 100644
--- a/www/drupal6-zeropoint/Makefile
+++ b/www/drupal6-zeropoint/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= whitekid@gmail.com
COMMENT= The zeropoint drupal theme
USE_PHP= ctype
+USE_DRUPAL= yes
DRUPAL6_THEME= yes
MODULE_DIRS= _custom/headerimg _custom css images/all images/ink \
images/icons/blocks images/icons images/ivy images/lime \
@@ -144,7 +145,4 @@ MODULE_FILES= _custom/custom-style.css _custom/headerimg/credits.txt \
views-view.tpl.php zeropoint.info
DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
-
+.include <bsd.port.mk>
diff --git a/www/drupal6/Makefile b/www/drupal6/Makefile
index 977718425c68..7e4c9046019d 100644
--- a/www/drupal6/Makefile
+++ b/www/drupal6/Makefile
@@ -15,6 +15,7 @@ DIST_SUBDIR= drupal
MAINTAINER= nick@foobar.org
COMMENT= A database driven web content management system (CMS)
+USE_DRUPAL= yes
DRUPAL6_PORT= yes
USE_PHP= gd pcre session xml mbstring
@@ -78,5 +79,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
.include <bsd.port.post.mk>
diff --git a/www/drupal7-wysiwyg/Makefile b/www/drupal7-wysiwyg/Makefile
index 63a0fa912851..af41023612cf 100644
--- a/www/drupal7-wysiwyg/Makefile
+++ b/www/drupal7-wysiwyg/Makefile
@@ -14,6 +14,8 @@ COMMENT= Allows implementation of WYSIWYG editors for editing Drupal content
#LICENSE from bsd.drupal.mk
+USE_DRUPAL= yes
+
OPTIONS= TINYMCE3 "Install TinyMCE3 Editor" off \
CKEDITOR "Install CKEditor" off \
YUI "Install Yahoo UI Editor" off
@@ -111,6 +113,4 @@ post-install:
${LN} -fs ${PREFIX}/www/yahoo ${PREFIX}/${DRUPAL_MODLIB}/yui
.endif
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index 2178e14d0dd0..a6f6111d6a96 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -15,6 +15,7 @@ DIST_SUBDIR= drupal
MAINTAINER= nick@foobar.org
COMMENT= A database driven web content management system (CMS)
+USE_DRUPAL= yes
DRUPAL_PORT= yes
DRUPAL_VERSION= 7
@@ -86,5 +87,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include "${PORTSDIR}/Mk/bsd.drupal.mk"
.include <bsd.port.post.mk>