aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/rtfm/Makefile4
-rw-r--r--misc/rtfm/files/patch-Makefile13
2 files changed, 14 insertions, 3 deletions
diff --git a/misc/rtfm/Makefile b/misc/rtfm/Makefile
index 199c2b82c0a2..840a18449e1b 100644
--- a/misc/rtfm/Makefile
+++ b/misc/rtfm/Makefile
@@ -10,8 +10,6 @@ MASTER_SITE_SUBDIR= chris
MAINTAINER= chris@FreeBSD.org
COMMENT= A FreeBSD documentation search mechanism
-MAN1= rtfm.1
-PLIST_FILES= bin/rtfm
+PLIST_FILES= bin/rtfm man/man1/rtfm.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/misc/rtfm/files/patch-Makefile b/misc/rtfm/files/patch-Makefile
new file mode 100644
index 000000000000..0f7f1a679f6a
--- /dev/null
+++ b/misc/rtfm/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2014-06-20 00:12:17.290047513 +0800
++++ Makefile 2014-06-20 00:12:43.436059870 +0800
+@@ -4,8 +4,8 @@ rtfm: rtfm.c
+ ${CC} -o rtfm rtfm.c ${CFLAGS} ${LDFLAGS}
+
+ install: rtfm
+- install -c -s -o root -g wheel -m 0755 rtfm /usr/local/bin
+- install -c -o root -g wheel -m 0644 rtfm.1 ${PREFIX}/man/man1
++ install -c -s -o root -g wheel -m 0755 rtfm $(DESTDIR)${PREFIX}/bin
++ install -c -o root -g wheel -m 0644 rtfm.1 $(DESTDIR)${PREFIX}/man/man1
+
+ clean:
+ rm -f rtfm