aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/sdl_gfx/Makefile7
-rw-r--r--graphics/sdl_gfx/pkg-plist10
2 files changed, 11 insertions, 6 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index b25f0b5f8171..91cad988d3a7 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sdl_gfx
PORTVERSION= 2.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.ferzkopp.net/Software/SDL_gfx-${PORTVERSION:R}/
DISTNAME= SDL_gfx-${PORTVERSION}
@@ -20,9 +20,14 @@ LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
INSTALLS_SHLIB= yes
+post-patch:
+ ${REINPLACE_CMD} 's,^libSDL_gfxincludedir.*,&/SDL11,' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/graphics/sdl_gfx/pkg-plist b/graphics/sdl_gfx/pkg-plist
index a0b6d6c04013..e0f99b76ca54 100644
--- a/graphics/sdl_gfx/pkg-plist
+++ b/graphics/sdl_gfx/pkg-plist
@@ -1,8 +1,8 @@
-include/SDL_framerate.h
-include/SDL_gfxPrimitives.h
-include/SDL_gfxPrimitives_font.h
-include/SDL_imageFilter.h
-include/SDL_rotozoom.h
+include/SDL11/SDL_framerate.h
+include/SDL11/SDL_gfxPrimitives.h
+include/SDL11/SDL_gfxPrimitives_font.h
+include/SDL11/SDL_imageFilter.h
+include/SDL11/SDL_rotozoom.h
lib/libSDL_gfx.a
lib/libSDL_gfx.so
lib/libSDL_gfx.so.0