aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/pinot/Makefile2
-rw-r--r--deskutils/pinot/files/patch-boost-spirit-13422
2 files changed, 23 insertions, 1 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index b88c12526e9e..74047204da0c 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pinot
PORTVERSION= 0.75
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
#MASTER_SITES= http://www.chez.com/colinf/pinot/ \
diff --git a/deskutils/pinot/files/patch-boost-spirit-134 b/deskutils/pinot/files/patch-boost-spirit-134
new file mode 100644
index 000000000000..d66a65b2b722
--- /dev/null
+++ b/deskutils/pinot/files/patch-boost-spirit-134
@@ -0,0 +1,22 @@
+--- Search/SherlockParser.cpp.orig Tue Jun 19 16:15:11 2007
++++ Search/SherlockParser.cpp Tue Aug 14 12:45:25 2007
+@@ -535,7 +535,8 @@
+ userInput, nextInput, nextFactor, nextValue);
+
+ parse_info<> parseInfo = boost::spirit::parse(pData, plugin, skip);
+- fullParsing = parseInfo.full;
++ //fullParsing = parseInfo.full;
++ fullParsing = parseInfo.hit;
+ }
+ else
+ {
+@@ -543,7 +544,8 @@
+ plugin_min_grammar plugin(searchParams);
+
+ parse_info<> parseInfo = boost::spirit::parse(pData, plugin, skip);
+- fullParsing = parseInfo.full;
++ //fullParsing = parseInfo.full;
++ fullParsing = parseInfo.hit;
+ }
+ }
+ catch (const exception &e)