aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/elixir/Makefile2
-rw-r--r--lang/elixir/files/patch-lib_elixir_src_elixir.erl17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/elixir/Makefile b/lang/elixir/Makefile
index 0e57374bde69..351b9cbebd3e 100644
--- a/lang/elixir/Makefile
+++ b/lang/elixir/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elixir
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MAINTAINER= lwhsu@FreeBSD.org
diff --git a/lang/elixir/files/patch-lib_elixir_src_elixir.erl b/lang/elixir/files/patch-lib_elixir_src_elixir.erl
new file mode 100644
index 000000000000..b59e7cf90222
--- /dev/null
+++ b/lang/elixir/files/patch-lib_elixir_src_elixir.erl
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- lib/elixir/src/elixir.erl.orig
++++ lib/elixir/src/elixir.erl
+@@ -29,9 +29,9 @@
+ end,
+
+ ok = io:setopts(standard_io, Opts),
+- %% Must use undocument {unicode, true} to set unicode on standard_error, more
++ %% Must use {encoding,unicode} to set unicode on standard_error, more
+ %% info: http://erlang.org/pipermail/erlang-bugs/2014-April/004310.html
+- ok = io:setopts(standard_error, [{unicode,true}]),
++ ok = io:setopts(standard_error, [{encoding,unicode}]),
+ case file:native_name_encoding() of
+ latin1 ->
+ io:format(standard_error,