aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/apachetop/Makefile2
-rw-r--r--sysutils/apachetop/files/patch-display.cc17
2 files changed, 18 insertions, 1 deletions
diff --git a/sysutils/apachetop/Makefile b/sysutils/apachetop/Makefile
index 2b15eaaa322e..dea5ec017a82 100644
--- a/sysutils/apachetop/Makefile
+++ b/sysutils/apachetop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apachetop
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://clueful.shagged.org/apachetop/files/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/apachetop/files/patch-display.cc b/sysutils/apachetop/files/patch-display.cc
new file mode 100644
index 000000000000..7d290b67173c
--- /dev/null
+++ b/sysutils/apachetop/files/patch-display.cc
@@ -0,0 +1,17 @@
+--- src/display.cc.orig Sun Feb 22 22:53:52 2004
++++ src/display.cc Sun Feb 22 22:54:16 2004
+@@ -238,8 +238,12 @@
+ * I'm fairly sure, realistically, it'll never get high enough to be
+ * a problem, so uInt should be ok */
+ if (items) free(items); /* get rid of the last one */
+- items = (struct itemlist *)
+- calloc((unsigned int)items_size, sizeof(itemlist));
++ if (items_size == 0) {
++ items = NULL;
++ } else {
++ items = (struct itemlist *)
++ calloc((unsigned int)items_size, sizeof(itemlist));
++ }
+
+ /* another thread may change the contents of cf while we're running,
+ * and it would be undesirable to have most of this change on us, so