aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/XFree86-aoutlibs/Makefile2
-rw-r--r--x11/XFree86-aoutlibs/pkg-req5
2 files changed, 4 insertions, 3 deletions
diff --git a/x11/XFree86-aoutlibs/Makefile b/x11/XFree86-aoutlibs/Makefile
index 9c3958efb925..ff3e2b05721f 100644
--- a/x11/XFree86-aoutlibs/Makefile
+++ b/x11/XFree86-aoutlibs/Makefile
@@ -23,7 +23,7 @@ PORTOBJFORMAT= aout
USE_X_PREFIX= yes
pre-configure:
- @${SETENV} ${SCRIPTS_ENV} ARCH=${ARCH} ${SH} \
+ @${SETENV} ${SCRIPTS_ENV} ${SH} \
${PKGDIR}/REQ ${PKGNAME} INSTALL
do-install:
diff --git a/x11/XFree86-aoutlibs/pkg-req b/x11/XFree86-aoutlibs/pkg-req
index a337c2fc9e53..aabd9bc76fbe 100644
--- a/x11/XFree86-aoutlibs/pkg-req
+++ b/x11/XFree86-aoutlibs/pkg-req
@@ -2,9 +2,10 @@
env=/usr/bin/env
fgrep=/usr/bin/fgrep
ldconfig=/sbin/ldconfig
-if [ x$2 = xINSTALL -a x$ARCH = xi386 ]; then
+ld_so=/usr/libexec/ld.so
+if [ x$2 = xINSTALL ]; then
$env OBJFORMAT=aout $ldconfig -r | $fgrep -q -e '-lc.3'
- if [ $? -ne 0 ]; then
+ if [ $? -ne 0 -o ! -x $ld_so ]; then
cat <<END
*********************************************************************