aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.sanity.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 12c271d6b7b2..5ae8c237662c 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -7,6 +7,15 @@
WARNING+= "WITHOUT_NLS is deprecated use OPTIONS_UNSET=NLS instead"
.endif
+.if defined(PKGORIGIN)
+.for _c in ${CATEGORIES}
+_CAT?= ${_c}
+.endfor
+.if ${.CURDIR:H:T} != ${_CAT}
+DEV_ERROR+= "The first entry in CATEGORIES should be the directory where the port lives"
+.endif
+.endif
+
#.if defined(WITHOUT_X11)
#WARNING+= "WITHOUT_X11 is deprecated use X11 option instead"
#.endif