aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/display/Makefile32
-rw-r--r--misc/display/distinfo2
-rw-r--r--misc/display/files/patch-aa59
-rw-r--r--misc/display/pkg-comment1
-rw-r--r--misc/display/pkg-descr4
-rw-r--r--misc/display/pkg-plist2
6 files changed, 100 insertions, 0 deletions
diff --git a/misc/display/Makefile b/misc/display/Makefile
new file mode 100644
index 000000000000..c4e9676f47f2
--- /dev/null
+++ b/misc/display/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: display
+# Version required: 1.0
+# Date created: 25 August 1997
+# Whom: Stephen J. Roznowski <sjr@home.net>
+#
+# $Id$
+#
+
+DISTNAME= display
+PKGNAME= display-1.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.unix/volume8/
+EXTRACT_SUFX=
+
+MAINTAINER= ports@FreeBSD.ORG
+
+PATCHFILES= display.pch.Z
+PATCH_SITES= ${MASTER_SITES}
+
+NO_WRKSUBDIR= yes
+
+BUILD_DEPENDS= gunshar:${PORTSDIR}/archivers/gshar+gunshar
+EXTRACT_CMD= gunshar
+EXTRACT_BEFORE_ARGS=
+
+MAN1= display.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/display ${PREFIX}/bin/display
+ @${INSTALL_MAN} ${WRKSRC}/display.man ${PREFIX}/man/man1/display.1
+
+.include <bsd.port.mk>
diff --git a/misc/display/distinfo b/misc/display/distinfo
new file mode 100644
index 000000000000..d67a4c165b60
--- /dev/null
+++ b/misc/display/distinfo
@@ -0,0 +1,2 @@
+MD5 (display) = 8b8833e1ae41dc1a3714ed1ba4776871
+MD5 (display.pch.Z) = c77e579b4dcc07fbf2dee01113029f0d
diff --git a/misc/display/files/patch-aa b/misc/display/files/patch-aa
new file mode 100644
index 000000000000..7145aba69342
--- /dev/null
+++ b/misc/display/files/patch-aa
@@ -0,0 +1,59 @@
+*** ../display.c Mon Aug 25 18:45:10 1997
+--- display.c Mon Aug 25 18:48:31 1997
+***************
+*** 8,13 ****
+--- 8,14 ----
+ #include <curses.h>
+ #include <signal.h>
+ #include <ctype.h>
++ #include <stdio.h>
+
+
+ #define DEFAULT_DELAY 5
+***************
+*** 16,30 ****
+ static char *Command;
+ static int Delay;
+
+
+ main(argc, argv)
+ int argc;
+ char *argv[];
+ {
+- extern void parse_args(),
+- die(),
+- display();
+-
+ parse_args(argc, argv);
+
+ signal(SIGHUP, die);
+--- 17,28 ----
+ static char *Command;
+ static int Delay;
+
++ static void die(), display(), parse_args(), usage();
+
+ main(argc, argv)
+ int argc;
+ char *argv[];
+ {
+ parse_args(argc, argv);
+
+ signal(SIGHUP, die);
+***************
+*** 54,60 ****
+
+ static void display()
+ {
+! auto FILE *fp, *popen();
+ auto char ch;
+
+ if (!(fp = popen(Command, "r"))) {
+--- 52,58 ----
+
+ static void display()
+ {
+! auto FILE *fp;
+ auto char ch;
+
+ if (!(fp = popen(Command, "r"))) {
diff --git a/misc/display/pkg-comment b/misc/display/pkg-comment
new file mode 100644
index 000000000000..bebd9a2b93a0
--- /dev/null
+++ b/misc/display/pkg-comment
@@ -0,0 +1 @@
+runs a specified command over and over.
diff --git a/misc/display/pkg-descr b/misc/display/pkg-descr
new file mode 100644
index 000000000000..6ff4305c1c35
--- /dev/null
+++ b/misc/display/pkg-descr
@@ -0,0 +1,4 @@
+Display runs a specified command over and over, printing the output
+through curses(3X). The command can be compound and the delay
+between executions is settable on the command line. The output
+from the command had better fit on a single screen, of course.
diff --git a/misc/display/pkg-plist b/misc/display/pkg-plist
new file mode 100644
index 000000000000..d5d6a33b7446
--- /dev/null
+++ b/misc/display/pkg-plist
@@ -0,0 +1,2 @@
+bin/display
+man/man1/display.1.gz