aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_wsgi/Makefile13
-rw-r--r--www/mod_wsgi/files/pkg-message.in9
-rw-r--r--www/mod_wsgi3/Makefile12
-rw-r--r--www/mod_wsgi3/files/pkg-message.in9
4 files changed, 35 insertions, 8 deletions
diff --git a/www/mod_wsgi/Makefile b/www/mod_wsgi/Makefile
index 564cda817520..fbeb7df33b88 100644
--- a/www/mod_wsgi/Makefile
+++ b/www/mod_wsgi/Makefile
@@ -16,10 +16,12 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
+LICENSE= ASL
+
MAKE_JOBS_SAFE= yes
LATEST_LINK= mod_wsgi2
-CONFLICTS= mod_wsgi-3.*
+CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi-3.*www/mod_wsgi-3.*
PROJECTHOST= modwsgi
@@ -30,8 +32,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}"
SUB_FILES= pkg-message
+
PORTSCOUT= limit:^2\.
+pre-everything::
+ @${ECHO_MSG} "======================= ATTENTION! ======================"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to use daemon mode you will need to make sure"
+ @${ECHO_MSG} "Apache and APR include thread support."
+ @${ECHO_MSG}
+ @${ECHO_MSG} "========================================================="
+
post-install:
@${APXS} -e -a -n "${SHORTMODNAME}" "${APACHEMODDIR}/${MODULENAME}.so"
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_wsgi/files/pkg-message.in b/www/mod_wsgi/files/pkg-message.in
index dea5054f301f..5c72392ba9d4 100644
--- a/www/mod_wsgi/files/pkg-message.in
+++ b/www/mod_wsgi/files/pkg-message.in
@@ -1,5 +1,8 @@
-================================================================================
+============================================================================
-For more information, see http://www.modwsgi.org/.
+If you want to use daemon mode you will need to make sure Apache and APR
+include thread support.
-================================================================================
+For more information, see http://www.modwsgi.org/wiki/InstallationOnFreeBSD.
+
+============================================================================
diff --git a/www/mod_wsgi3/Makefile b/www/mod_wsgi3/Makefile
index c51409659392..555201d979cc 100644
--- a/www/mod_wsgi3/Makefile
+++ b/www/mod_wsgi3/Makefile
@@ -17,10 +17,12 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
+LICENSE= ASL
+
MAKE_JOBS_SAFE= yes
#LATEST_LINK= mod_wsgi
-CONFLICTS= mod_wsgi-2.*
+CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi-2.*www/mod_wsgi-2.*
PROJECTHOST= modwsgi
@@ -38,6 +40,14 @@ SUB_FILES= pkg-message
IGNORE= is unsupported with Python 3.0
.endif
+pre-everything::
+ @${ECHO_MSG} "======================= ATTENTION! ======================"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to use daemon mode you will need to make sure"
+ @${ECHO_MSG} "Apache and APR include thread support."
+ @${ECHO_MSG}
+ @${ECHO_MSG} "========================================================="
+
post-install:
@${APXS} -e -a -n "${SHORTMODNAME}" "${APACHEMODDIR}/${MODULENAME}.so"
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_wsgi3/files/pkg-message.in b/www/mod_wsgi3/files/pkg-message.in
index dea5054f301f..5c72392ba9d4 100644
--- a/www/mod_wsgi3/files/pkg-message.in
+++ b/www/mod_wsgi3/files/pkg-message.in
@@ -1,5 +1,8 @@
-================================================================================
+============================================================================
-For more information, see http://www.modwsgi.org/.
+If you want to use daemon mode you will need to make sure Apache and APR
+include thread support.
-================================================================================
+For more information, see http://www.modwsgi.org/wiki/InstallationOnFreeBSD.
+
+============================================================================